CVE-2022-36049 Flux2 Helm Controller denial of service
A tenant can cause the Helm controller to panic via high memory consumption, denying service to other tenants in shared clusters.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-36049?
CVE-2022-36049 is a high-severity denial of service vulnerability in fluxcd flux2, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Flux2 is a tool for keeping Kubernetes clusters in sync with sources of configuration, and Flux's helm-controller is a Kubernetes operator that allows one to declaratively manage Helm chart releases. Helm controller is tightly integrated with the Helm SDK. A vulnerability found in the Helm SDK that affects flux2 v0.0.17 until v0.32.0 and helm-controller v0.0.4 until v0.23.0 allows for specific data inputs to cause high memory consumption. In some platforms, this could cause the controller to panic and stop processing reconciliations. In a shared cluster multi-tenancy environment, a tenant could create a HelmRelease that makes the controller panic, denying all other tenants from their Helm releases being reconciled. Patches are available in flux2 v0.32.0 and helm-controller v0.23.0.
Which versions are affected by CVE-2022-36049?
6 open source packages ship an affected version, including github.com/fluxcd/flux2, flux and helm. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/fluxcd/flux2 Go | From 0.0.17 | 0.32.0 |
github.com/fluxcd/flux2 Go | From 0.0.17 | 0.32.0 |
flux Bitnami | From 0.0.17 | 0.32.0 |
helm Bitnami | From 3.0.0 | 3.9.4 |
github.com/fluxcd/helm-controller Go | From 0.0.4 | 0.23.0 |
github.com/fluxcd/helm-controller Go | From 0.0.4 | 0.23.0 |
Products include Fluxcd Flux2, Fluxcd Helm-Controller, Helm Helm.
How do I fix CVE-2022-36049?
Upgrade github.com/fluxcd/flux2 to 0.32.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-36049 being exploited?
There is no known exploitation of CVE-2022-36049 in the wild and no public exploit code.
Other vulnerabilities in fluxcd flux2
- CVE-2022-24817 Improper kubeconfig validation allows arbitrary code execution
- CVE-2022-24877 Improper path handling in kustomization files allows path traversal
- CVE-2022-36035 Flux CLI Workload Injection
- CVE-2022-24878 Improper path handling in Kustomization files allows for denial of service
- CVE-2022-39272 Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration
Sources
Also known as AZL-10900, BIT-flux-2022-36049, BIT-helm-2022-36049, GHSA-p2g7-xwvr-rrw3.