# CVE-2022-36049: Flux2 Helm Controller denial of service

> A tenant can cause the Helm controller to panic via high memory consumption, denying service to other tenants in shared clusters.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** AZL-10900, BIT-flux-2022-36049, BIT-helm-2022-36049, GHSA-p2g7-xwvr-rrw3

## What is CVE-2022-36049?

CVE-2022-36049 is a high-severity denial of service vulnerability in fluxcd flux2, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flux2 is a tool for keeping Kubernetes clusters in sync with sources of configuration, and Flux's helm-controller is a Kubernetes operator that allows one to declaratively manage Helm chart releases. Helm controller is tightly integrated with the Helm SDK. A vulnerability found in the Helm SDK that affects flux2 v0.0.17 until v0.32.0 and helm-controller v0.0.4 until v0.23.0 allows for specific data inputs to cause high memory consumption. In some platforms, this could cause the controller to panic and stop processing reconciliations. In a shared cluster multi-tenancy environment, a tenant could create a HelmRelease that makes the controller panic, denying all other tenants from their Helm releases being reconciled. Patches are available in flux2 v0.32.0 and helm-controller v0.23.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-36049?

6 open source packages ship an affected version, including github.com/fluxcd/flux2, flux and helm. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluxcd/flux2` | Go | From 0.0.17 | 0.32.0 |
| `github.com/fluxcd/flux2` | Go | From 0.0.17 | 0.32.0 |
| `flux` | Bitnami | From 0.0.17 | 0.32.0 |
| `helm` | Bitnami | From 3.0.0 | 3.9.4 |
| `github.com/fluxcd/helm-controller` | Go | From 0.0.4 | 0.23.0 |
| `github.com/fluxcd/helm-controller` | Go | From 0.0.4 | 0.23.0 |

Products: Fluxcd Flux2, Fluxcd Helm-Controller, Helm Helm.

## How do I fix CVE-2022-36049?

Upgrade github.com/fluxcd/flux2 to 0.32.0 or later.

## Is CVE-2022-36049 being exploited?

There is no known exploitation of CVE-2022-36049 in the wild and no public exploit code.

## Other vulnerabilities in fluxcd flux2

- [CVE-2022-24817](https://insights.sbomify.com/CVE-2022-24817/): Improper kubeconfig validation allows arbitrary code execution (critical 9.9)
- [CVE-2022-24877](https://insights.sbomify.com/CVE-2022-24877/): Improper path handling in kustomization files allows path traversal (critical 9.9)
- [CVE-2022-36035](https://insights.sbomify.com/CVE-2022-36035/): Flux CLI Workload Injection (high 7.7)
- [CVE-2022-24878](https://insights.sbomify.com/CVE-2022-24878/): Improper path handling in Kustomization files allows for denial of service (high 7.7)
- [CVE-2022-39272](https://insights.sbomify.com/CVE-2022-39272/): Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36049 and fix it if it is affected.

What it is: CVE-2022-36049 is a high-severity denial of service vulnerability in fluxcd flux2, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36049 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluxcd/flux2 (Go): affected from 0.0.17; fixed in 0.32.0
- github.com/fluxcd/flux2 (Go): affected from 0.0.17; fixed in 0.32.0
- flux (Bitnami): affected from 0.0.17; fixed in 0.32.0
- helm (Bitnami): affected from 3.0.0; fixed in 3.9.4
- github.com/fluxcd/helm-controller (Go): affected from 0.0.4; fixed in 0.23.0
- github.com/fluxcd/helm-controller (Go): affected from 0.0.4; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36049/ (Markdown: https://insights.sbomify.com/CVE-2022-36049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36049
- OSV: https://osv.dev/vulnerability/CVE-2022-36049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36049/
Summaries are generated and may contain mistakes; the official description above is the record.
