CVE-2022-36055 Denial of service in Helm
Attackers can cause a denial of service in Helm by providing specific input to value-setting flags, triggering an unrecoverable out-of-memory panic.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-36055?
CVE-2022-36055 is a medium-severity denial of service vulnerability in helm, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Helm is a tool for managing Charts. Charts are packages of pre-configured Kubernetes resources. Fuzz testing, provided by the CNCF, identified input to functions in the _strvals_ package that can cause an out of memory panic. The _strvals_ package contains a parser that turns strings in to Go structures. The _strvals_ package converts these strings into structures Go can work with. Some string inputs can cause array data structures to be created causing an out of memory panic. Applications that use the _strvals_ package in the Helm SDK to parse user supplied input can suffer a Denial of Service when that input causes a panic that cannot be recovered from. The Helm Client will panic with input to `--set`, `--set-string`, and other value setting flags that causes an out of memory panic. Helm is not a long running service so the panic will not affect future uses of the Helm client. This issue has been resolved in 3.9.4. SDK users can validate strings supplied by users won't create large arrays causing significant memory usage before passing them to the _strvals_ functions.
Which versions are affected by CVE-2022-36055?
4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
helm.sh/helm/v3 Go | All versions | 3.9.4 |
helm.sh/helm/v3 Go | All versions | 3.9.4 |
helm.sh/helm/v3 Go | All versions | 3.9.4 |
helm Bitnami | From 3.0.0 | 3.9.4 |
Linux distribution packages (1)
helm openSUSE:Tumbleweed | All versions | 3.9.4-2.1 |
Products include Helm Helm.
How do I fix CVE-2022-36055?
Upgrade helm.sh/helm/v3 to 3.9.4 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-36055 being exploited?
There is no known exploitation of CVE-2022-36055 in the wild and no public exploit code.
Other vulnerabilities in helm
- CVE-2019-18658 Helm Unsafe Link Following
- CVE-2019-1010275 Helm Improper Certificate Validation
- CVE-2019-25210 Information disclosure in n/a
- CVE-2025-53547 Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution
- CVE-2020-11013 lookup Function Information Discolosure in Helm
Sources
Also known as AZL-10856, BIT-helm-2022-36055, CLEANSTART-2026-BN36919, GHSA-7hfp-qfw3-5jxh, GO-2022-0962, openSUSE-SU-2024:12323-1.