# CVE-2022-36055: Denial of service in Helm

> Attackers can cause a denial of service in Helm by providing specific input to value-setting flags, triggering an unrecoverable out-of-memory panic.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** AZL-10856, BIT-helm-2022-36055, CLEANSTART-2026-BN36919, GHSA-7hfp-qfw3-5jxh, GO-2022-0962, openSUSE-SU-2024:12323-1

## What is CVE-2022-36055?

CVE-2022-36055 is a medium-severity denial of service vulnerability in helm, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Helm is a tool for managing Charts. Charts are packages of pre-configured Kubernetes resources. Fuzz testing, provided by the CNCF, identified input to functions in the _strvals_ package that can cause an out of memory panic. The _strvals_ package contains a parser that turns strings in to Go structures. The _strvals_ package converts these strings into structures Go can work with. Some string inputs can cause array data structures to be created causing an out of memory panic. Applications that use the _strvals_ package in the Helm SDK to parse user supplied input can suffer a Denial of Service when that input causes a panic that cannot be recovered from. The Helm Client will panic with input to `--set`, `--set-string`, and other value setting flags that causes an out of memory panic. Helm is not a long running service so the panic will not affect future uses of the Helm client. This issue has been resolved in 3.9.4. SDK users can validate strings supplied by users won't create large arrays causing significant memory usage before passing them to the _strvals_ functions.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-36055?

4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.9.4 |
| `helm.sh/helm/v3` | Go | All versions | 3.9.4 |
| `helm.sh/helm/v3` | Go | All versions | 3.9.4 |
| `helm` | Bitnami | From 3.0.0 | 3.9.4 |
| `helm` | openSUSE:Tumbleweed | All versions | 3.9.4-2.1 |

Products: Helm Helm.

## How do I fix CVE-2022-36055?

Upgrade helm.sh/helm/v3 to 3.9.4 or later.

## Is CVE-2022-36055 being exploited?

There is no known exploitation of CVE-2022-36055 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36055 and fix it if it is affected.

What it is: CVE-2022-36055 is a medium-severity denial of service vulnerability in helm, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36055 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.9.4
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.9.4
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.9.4
- helm (Bitnami): affected from 3.0.0; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36055/ (Markdown: https://insights.sbomify.com/CVE-2022-36055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36055
- OSV: https://osv.dev/vulnerability/CVE-2022-36055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36055/
Summaries are generated and may contain mistakes; the official description above is the record.
