CVE-2022-36056 Vulnerabilities with blob verification in sigstore cosign
Attackers can bypass signature verification in Cosign by crafting invalid bundles or omitting identity checks, allowing unsigned artifacts to appear verified.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-36056?
CVE-2022-36056 is a medium-severity vulnerability in sigstore cosign, published on 14 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Cosign is a project under the sigstore organization which aims to make signatures invisible infrastructure. In versions prior to 1.12.0 a number of vulnerabilities have been found in cosign verify-blob, where Cosign would successfully verify an artifact when verification should have failed. First a cosign bundle can be crafted to successfully verify a blob even if the embedded rekorBundle does not reference the given signature. Second, when providing identity flags, the email and issuer of a certificate is not checked when verifying a Rekor bundle, and the GitHub Actions identity is never checked. Third, providing an invalid Rekor bundle without the experimental flag results in a successful verification. And fourth an invalid transparency log entry will result in immediate success for verification. Details and examples of these issues can be seen in the GHSA-8gw7-4j42-w388 advisory linked. Users are advised to upgrade to 1.12.0. There are no known workarounds for these issues.
Weakness: CWE-347
Which versions are affected by CVE-2022-36056?
4 open source packages ship an affected version, including github.com/sigstore/cosign and cosign. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/sigstore/cosign Go | All versions | 1.12.0 |
github.com/sigstore/cosign Go | All versions | 1.12.0 |
github.com/sigstore/cosign Go | All versions | 1.12.0 |
cosign Bitnami | All versions | 1.12.0 |
Linux distribution packages (3)
cosign SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.12.0-150400.3.6.1 |
cosign openSUSE:Leap 15.4 | All versions | 1.12.0-150400.3.6.1 |
cosign openSUSE:Tumbleweed | All versions | 1.12.0-1.1 |
Products include Sigstore Cosign.
How do I fix CVE-2022-36056?
Upgrade github.com/sigstore/cosign to 1.12.0 or later.
Is CVE-2022-36056 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36056 exists.
Other vulnerabilities in sigstore cosign
- CVE-2022-35929 False positive signature verification in cosign
- CVE-2026-22703 Cosign verification accepts any valid Rekor entry under certain conditions
- CVE-2026-39395 Cosign's verify-blob-attestation reports false positive when payload parsing fails
- CVE-2024-29902 Cosign vulnerable to system-wide denial of service via malicious attachments
- CVE-2024-29903 Cosign vulnerable to machine-wide denial of service via malicious artifacts
Sources
Also known as BIT-cosign-2022-36056, CLEANSTART-2026-OH46796, GHSA-8gw7-4j42-w388, GO-2022-0998, SUSE-SU-2022:3486-1, openSUSE-SU-2024:12331-1.