# CVE-2022-36056: Vulnerabilities with blob verification in sigstore cosign

> Attackers can bypass signature verification in Cosign by crafting invalid bundles or omitting identity checks, allowing unsigned artifacts to appear verified.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-cosign-2022-36056, CLEANSTART-2026-OH46796, GHSA-8gw7-4j42-w388, GO-2022-0998, SUSE-SU-2022:3486-1, openSUSE-SU-2024:12331-1

## What is CVE-2022-36056?

CVE-2022-36056 is a medium-severity vulnerability in sigstore cosign, published on 14 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cosign is a project under the sigstore organization which aims to make signatures invisible infrastructure. In versions prior to 1.12.0 a number of vulnerabilities have been found in cosign verify-blob, where Cosign would successfully verify an artifact when verification should have failed. First a cosign bundle can be crafted to successfully verify a blob even if the embedded rekorBundle does not reference the given signature. Second, when providing identity flags, the email and issuer of a certificate is not checked when verifying a Rekor bundle, and the GitHub Actions identity is never checked. Third, providing an invalid Rekor bundle without the experimental flag results in a successful verification. And fourth an invalid transparency log entry will result in immediate success for verification. Details and examples of these issues can be seen in the GHSA-8gw7-4j42-w388 advisory linked. Users are advised to upgrade to 1.12.0. There are no known workarounds for these issues.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2022-36056?

4 open source packages ship an affected version, including github.com/sigstore/cosign and cosign. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/cosign` | Go | All versions | 1.12.0 |
| `github.com/sigstore/cosign` | Go | All versions | 1.12.0 |
| `github.com/sigstore/cosign` | Go | All versions | 1.12.0 |
| `cosign` | Bitnami | All versions | 1.12.0 |
| `cosign` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.12.0-150400.3.6.1 |
| `cosign` | openSUSE:Leap 15.4 | All versions | 1.12.0-150400.3.6.1 |
| `cosign` | openSUSE:Tumbleweed | All versions | 1.12.0-1.1 |

Products: Sigstore Cosign.

## How do I fix CVE-2022-36056?

Upgrade github.com/sigstore/cosign to 1.12.0 or later.

## Is CVE-2022-36056 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36056 exists.

## Other vulnerabilities in sigstore cosign

- [CVE-2022-35929](https://insights.sbomify.com/CVE-2022-35929/): False positive signature verification in cosign (high 7.1)
- [CVE-2026-22703](https://insights.sbomify.com/CVE-2026-22703/): Cosign verification accepts any valid Rekor entry under certain conditions (medium 5.5)
- [CVE-2026-39395](https://insights.sbomify.com/CVE-2026-39395/): Cosign's verify-blob-attestation reports false positive when payload parsing fails (medium 4.3)
- [CVE-2024-29902](https://insights.sbomify.com/CVE-2024-29902/): Cosign vulnerable to system-wide denial of service via malicious attachments (medium 4.2)
- [CVE-2024-29903](https://insights.sbomify.com/CVE-2024-29903/): Cosign vulnerable to machine-wide denial of service via malicious artifacts (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36056 and fix it if it is affected.

What it is: CVE-2022-36056 is a medium-severity vulnerability in sigstore cosign, published on 14 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36056 exists.

Affected packages and fixed versions:
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.12.0
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.12.0
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.12.0
- cosign (Bitnami): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36056/ (Markdown: https://insights.sbomify.com/CVE-2022-36056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36056
- OSV: https://osv.dev/vulnerability/CVE-2022-36056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36056/
Summaries are generated and may contain mistakes; the official description above is the record.
