CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file

Critical 9.1 Published Updated

Administrators can achieve remote code execution by uploading maliciously crafted Zip or Gzip Tar archives to the Discourse platform.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-36066?

CVE-2022-36066 is a critical vulnerability in Discourse Discourse, published on 29 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, admins can upload a maliciously crafted Zip or Gzip Tar archive to write files at arbitrary locations and trigger remote code execution. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-434

Which versions are affected by CVE-2022-36066?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.9

Products include Discourse Discourse.

How do I fix CVE-2022-36066?

Upgrade discourse to 2.8.9 or later.

Is CVE-2022-36066 being exploited?

There is no known exploitation of CVE-2022-36066 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-36066, GHSA-grvh-qcpg-hfmv.

Is CVE-2022-36066 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free