CVE-2022-36068 Discourse moderators can edit themes via the API

High 7.2 Published Updated

Moderators can improperly edit themes via the API, allowing unauthorized modification of site appearance and potential security bypass.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-36068?

CVE-2022-36068 is a high-severity missing authorization vulnerability in Discourse Discourse, published on 29 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a moderator can create new and edit existing themes by using the API when they should not be able to do so. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-862

Which versions are affected by CVE-2022-36068?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.9

Products include Discourse Discourse.

How do I fix CVE-2022-36068?

Upgrade discourse to 2.8.9 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-36068 being exploited?

There is no known exploitation of CVE-2022-36068 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-36068, GHSA-6crr-3662-263q.

Is CVE-2022-36068 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free