{"answers":{"affected":"3 open source packages ship an affected version, including poetry. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36069 exists.","fix":"Upgrade poetry to 1.1.9 or later.","what":"CVE-2022-36069 is a high-severity command injection vulnerability in python-poetry poetry, published on 7 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-36069 and fix it if it is affected.\n\nWhat it is: CVE-2022-36069 is a high-severity command injection vulnerability in python-poetry poetry, published on 7 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36069 exists.\n\nAffected packages and fixed versions:\n- poetry (PyPI): affected all versions; fixed in 1.1.9\n- poetry (PyPI): affected all versions; fixed in 1.1.9\n- poetry (PyPI): affected all versions; fixed in 1.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36069/ (Markdown: https://insights.sbomify.com/CVE-2022-36069/index.md)","id":"CVE-2022-36069","markdown":"https://insights.sbomify.com/CVE-2022-36069/index.md","name":"CVE-2022-36069","record":{"aliases":["AZL-10919","DEBIAN-CVE-2022-36069","GHSA-9xgj-fcgf-x6mw","PYSEC-2022-266","UBUNTU-CVE-2022-36069"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python dependency manager","requires_auth":"low_privilege","summary":"Attackers can achieve local code execution by injecting arguments via malicious Git repository URLs in Poetry.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"poetry","vendor":"python-poetry"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Poetry is a dependency manager for Python. When handling dependencies that come from a Git repository instead of a registry, Poetry uses various commands, such as `git clone`. These commands are constructed using user input (e.g. the repository URL). When building the commands, Poetry correctly avoids Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. If a developer is exploited, the attacker could steal credentials or persist their access. If the exploit happens on a server, the attackers could use their access to attack other internal systems. Since this vulnerability requires a fair amount of user interaction, it is not as dangerous as a remotely exploitable one. However, it still puts developers at risk when dealing with untrusted files in a way they think is safe, because the exploit still works when the victim tries to make sure nothing can happen, e.g. by vetting any Git or Poetry config files that might be present in the directory. Versions 1.1.9 and 1.2.0b1 contain patches for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Poetry Argument Injection vulnerability can lead to local Code Execution","id":"CVE-2022-36069","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Poetry's Untrusted Search Path can lead to Local Code Execution on Windows","id":"CVE-2022-36070"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.9"],"introduced":["0"],"last_affected":[],"package":"poetry","purl":null,"source":"GHSA-9xgj-fcgf-x6mw"},{"ecosystem":"PyPI","fixed":["1.1.9"],"introduced":["0"],"last_affected":[],"package":"poetry","purl":"pkg:pypi/poetry","source":"GHSA-9xgj-fcgf-x6mw"},{"ecosystem":"PyPI","fixed":["1.1.9"],"introduced":["0"],"last_affected":[],"package":"poetry","purl":"pkg:pypi/poetry","source":"PYSEC-2022-266"}],"prev":{"headline":"Discourse moderators can edit themes via the API","id":"CVE-2022-36068"},"products":["poetry"],"published":"2022-09-07","related":[{"cvss_score":9.8,"headline":"Poetry before v1.1.9 contains Untrusted Search Path","id":"CVE-2022-26184","kev_date_added":null,"published":"2022-03-21"},{"cvss_score":7.3,"headline":"Poetry's Untrusted Search Path can lead to Local Code Execution on Windows","id":"CVE-2022-36070","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":7.1,"headline":"Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write","id":"CVE-2026-34591","kev_date_added":null,"published":"2026-04-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["python-poetry"]},"summary":"Attackers can achieve local code execution by injecting arguments via malicious Git repository URLs in Poetry.","url":"https://insights.sbomify.com/CVE-2022-36069/"}