# CVE-2022-36069: Poetry Argument Injection vulnerability can lead to local Code Execution

> Attackers can achieve local code execution by injecting arguments via malicious Git repository URLs in Poetry.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** AZL-10919, DEBIAN-CVE-2022-36069, GHSA-9xgj-fcgf-x6mw, PYSEC-2022-266, UBUNTU-CVE-2022-36069

## What is CVE-2022-36069?

CVE-2022-36069 is a high-severity command injection vulnerability in python-poetry poetry, published on 7 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Poetry is a dependency manager for Python. When handling dependencies that come from a Git repository instead of a registry, Poetry uses various commands, such as `git clone`. These commands are constructed using user input (e.g. the repository URL). When building the commands, Poetry correctly avoids Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. If a developer is exploited, the attacker could steal credentials or persist their access. If the exploit happens on a server, the attackers could use their access to attack other internal systems. Since this vulnerability requires a fair amount of user interaction, it is not as dangerous as a remotely exploitable one. However, it still puts developers at risk when dealing with untrusted files in a way they think is safe, because the exploit still works when the victim tries to make sure nothing can happen, e.g. by vetting any Git or Poetry config files that might be present in the directory. Versions 1.1.9 and 1.2.0b1 contain patches for this issue.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-36069?

3 open source packages ship an affected version, including poetry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `poetry` | PyPI | All versions | 1.1.9 |
| `poetry` | PyPI | All versions | 1.1.9 |
| `poetry` | PyPI | All versions | 1.1.9 |

Products: Python-Poetry Poetry.

## How do I fix CVE-2022-36069?

Upgrade poetry to 1.1.9 or later.

## Is CVE-2022-36069 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36069 exists.

## Other vulnerabilities in python-poetry poetry

- [CVE-2022-26184](https://insights.sbomify.com/CVE-2022-26184/): Poetry before v1.1.9 contains Untrusted Search Path (critical 9.8)
- [CVE-2022-36070](https://insights.sbomify.com/CVE-2022-36070/): Poetry's Untrusted Search Path can lead to Local Code Execution on Windows (high 7.3)
- [CVE-2026-34591](https://insights.sbomify.com/CVE-2026-34591/): Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36069 and fix it if it is affected.

What it is: CVE-2022-36069 is a high-severity command injection vulnerability in python-poetry poetry, published on 7 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36069 exists.

Affected packages and fixed versions:
- poetry (PyPI): affected all versions; fixed in 1.1.9
- poetry (PyPI): affected all versions; fixed in 1.1.9
- poetry (PyPI): affected all versions; fixed in 1.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36069/ (Markdown: https://insights.sbomify.com/CVE-2022-36069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36069
- OSV: https://osv.dev/vulnerability/CVE-2022-36069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36069/
Summaries are generated and may contain mistakes; the official description above is the record.
