# CVE-2022-36070: Poetry's Untrusted Search Path can lead to Local Code Execution on Windows

> Attackers can execute arbitrary code on Windows by placing malicious executables in the current directory, exploiting Poetry's untrusted search path behavior.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-j4j9-7hg9-97g6, PYSEC-2022-43179

## What is CVE-2022-36070?

CVE-2022-36070 is a high-severity code injection vulnerability in python-poetry poetry, published on 7 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Poetry is a dependency manager for Python. To handle dependencies that come from a Git repository, Poetry executes various commands, e.g. `git config`. These commands are being executed using the executable’s name and not its absolute path. This can lead to the execution of untrusted code due to the way Windows resolves executable names to paths. Unlike Linux-based operating systems, Windows searches for the executable in the current directory first and looks in the paths that are defined in the `PATH` environment variable afterward. This vulnerability can lead to Arbitrary Code Execution, which would lead to the takeover of the system. If a developer is exploited, the attacker could steal credentials or persist their access. If the exploit happens on a server, the attackers could use their access to attack other internal systems. Since this vulnerability requires a fair amount of user interaction, it is not as dangerous as a remotely exploitable one. However, it still puts developers at risk when dealing with untrusted files in a way they think is safe. The victim could also not protect themself by vetting any Git or Poetry config files that might be present in the directory, because the behavior is undocumented. Versions 1.1.9 and 1.2.0b1 contain patches for this issue.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2022-36070?

3 open source packages ship an affected version, including poetry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `poetry` | PyPI | All versions | 1.1.9 |
| `poetry` | PyPI | All versions | 1.1.9 |
| `poetry` | PyPI | All versions | 1.1.9 |

Products: Python-Poetry Poetry.

## How do I fix CVE-2022-36070?

Upgrade poetry to 1.1.9 or later.

## Is CVE-2022-36070 being exploited?

There is no known exploitation of CVE-2022-36070 in the wild and no public exploit code.

## Other vulnerabilities in python-poetry poetry

- [CVE-2022-26184](https://insights.sbomify.com/CVE-2022-26184/): Poetry before v1.1.9 contains Untrusted Search Path (critical 9.8)
- [CVE-2022-36069](https://insights.sbomify.com/CVE-2022-36069/): Poetry Argument Injection vulnerability can lead to local Code Execution (high 7.3)
- [CVE-2026-34591](https://insights.sbomify.com/CVE-2026-34591/): Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36070 and fix it if it is affected.

What it is: CVE-2022-36070 is a high-severity code injection vulnerability in python-poetry poetry, published on 7 Sep 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36070 in the wild and no public exploit code.

Affected packages and fixed versions:
- poetry (PyPI): affected all versions; fixed in 1.1.9
- poetry (PyPI): affected all versions; fixed in 1.1.9
- poetry (PyPI): affected all versions; fixed in 1.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36070/ (Markdown: https://insights.sbomify.com/CVE-2022-36070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36070
- OSV: https://osv.dev/vulnerability/CVE-2022-36070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36070/
Summaries are generated and may contain mistakes; the official description above is the record.
