# CVE-2022-36076: Account takeover via SSO plugins in NodeBB

> Attackers can take over user accounts via MITM attacks during SSO due to missing nonce checks in NodeBB forum software.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-xmgg-fx9p-prq6

## What is CVE-2022-36076?

CVE-2022-36076 is a high-severity vulnerability in NodeBB, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NodeBB Forum Software is powered by Node.js and supports either Redis, MongoDB, or a PostgreSQL database. Due to an unnecessarily strict conditional in the code handling the first step of the SSO process, the pre-existing logic that added (and later checked) a nonce was inadvertently rendered opt-in instead of opt-out. This re-exposed a vulnerability in that a specially crafted Man-in-the-Middle (MITM) attack could theoretically take over another user account during the single sign-on process. The issue has been fully patched in version 1.17.2.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-36076?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | All versions | 1.17.2 |
| `nodebb` | npm | All versions | 1.17.2 |

Products: Nodebb Nodebb.

## How do I fix CVE-2022-36076?

Upgrade nodebb to 1.17.2 or later.

## Is CVE-2022-36076 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36076 exists.

## Other vulnerabilities in NodeBB

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2021-43786](https://insights.sbomify.com/CVE-2021-43786/): API token verification can be bypassed (critical 9.8)
- [CVE-2022-46164](https://insights.sbomify.com/CVE-2022-46164/): Account takeover via prototype vulnerability (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36076 and fix it if it is affected.

What it is: CVE-2022-36076 is a high-severity vulnerability in NodeBB, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36076 exists.

Affected packages and fixed versions:
- nodebb (npm): affected all versions; fixed in 1.17.2
- nodebb (npm): affected all versions; fixed in 1.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36076/ (Markdown: https://insights.sbomify.com/CVE-2022-36076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36076
- OSV: https://osv.dev/vulnerability/CVE-2022-36076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36076/
Summaries are generated and may contain mistakes; the official description above is the record.
