CVE-2022-36079 Parse Server vulnerable to brute force guessing of user sensitive data via search patterns

High 8.6 Published Updated

Attackers can brute-force guess internal and protected user fields via search patterns, exposing sensitive data in Parse Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-36079?

CVE-2022-36079 is a high-severity vulnerability in Parseplatform Parse-Server, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Internal fields (keys used internally by Parse Server, prefixed by `_`) and protected fields (user defined) can be used as query constraints. Internal and protected fields are removed by Parse Server and are only returned to the client using a valid master key. However, using query constraints, these fields can be guessed by enumerating until Parse Server, prior to versions 4.10.14 or 5.2.5, returns a response object. The patch available in versions 4.10.14 and 5.2.5 requires the maser key to use internal and protected fields as query constraints. As a workaround, implement a Parse Cloud Trigger `beforeFind` and manually remove the query constraints.

Weakness: CWE-200

Which versions are affected by CVE-2022-36079?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions4.10.14
parse-server npmAll versions4.10.14
parse-server npmFrom 5.0.05.2.5
parse-server npmFrom 5.0.05.2.5
parse BitnamiAll versions4.10.14, 5.2.5

Products include Parseplatform Parse-Server.

How do I fix CVE-2022-36079?

Upgrade parse-server to a fixed version for your release line: 4.10.14 or 5.2.5.

Is CVE-2022-36079 being exploited?

There is no known exploitation of CVE-2022-36079 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2022-36079, GHSA-2m6g-crv8-p3c6.

Is CVE-2022-36079 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free