# CVE-2022-36079: Parse Server vulnerable to brute force guessing of user sensitive data via search patterns

> Attackers can brute-force guess internal and protected user fields via search patterns, exposing sensitive data in Parse Server.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-parse-2022-36079, GHSA-2m6g-crv8-p3c6

## What is CVE-2022-36079?

CVE-2022-36079 is a high-severity vulnerability in Parseplatform Parse-Server, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Internal fields (keys used internally by Parse Server, prefixed by `_`) and protected fields (user defined) can be used as query constraints. Internal and protected fields are removed by Parse Server and are only returned to the client using a valid master key. However, using query constraints, these fields can be guessed by enumerating until Parse Server, prior to versions 4.10.14 or 5.2.5, returns a response object. The patch available in versions 4.10.14 and 5.2.5 requires the maser key to use internal and protected fields as query constraints. As a workaround, implement a Parse Cloud Trigger `beforeFind` and manually remove the query constraints.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-36079?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.14 |
| `parse-server` | npm | All versions | 4.10.14 |
| `parse-server` | npm | From 5.0.0 | 5.2.5 |
| `parse-server` | npm | From 5.0.0 | 5.2.5 |
| `parse` | Bitnami | All versions | 4.10.14, 5.2.5 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2022-36079?

Upgrade parse-server to a fixed version for your release line: 4.10.14 or 5.2.5.

## Is CVE-2022-36079 being exploited?

There is no known exploitation of CVE-2022-36079 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36079 and fix it if it is affected.

What it is: CVE-2022-36079 is a high-severity vulnerability in Parseplatform Parse-Server, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36079 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.14
- parse-server (npm): affected all versions; fixed in 4.10.14
- parse-server (npm): affected from 5.0.0; fixed in 5.2.5
- parse-server (npm): affected from 5.0.0; fixed in 5.2.5
- parse (Bitnami): affected all versions; fixed in 4.10.14, 5.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36079/ (Markdown: https://insights.sbomify.com/CVE-2022-36079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36079
- OSV: https://osv.dev/vulnerability/CVE-2022-36079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36079/
Summaries are generated and may contain mistakes; the official description above is the record.
