{"answers":{"affected":"4 open source packages ship an affected version, including cruddl. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36084 in the wild and no public exploit code.","fix":"Upgrade cruddl to a fixed version for your release line: 2.7.0 or 3.0.2.","what":"CVE-2022-36084 is a critical code injection vulnerability in AEB-labs cruddl, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36084 and fix it if it is affected.\n\nWhat it is: CVE-2022-36084 is a critical code injection vulnerability in AEB-labs cruddl, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36084 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cruddl (npm): affected from 1.1.0; fixed in 2.7.0\n- cruddl (npm): affected from 1.1.0; fixed in 2.7.0\n- cruddl (npm): affected from 3.0.0; fixed in 3.0.2\n- cruddl (npm): affected from 3.0.0; fixed in 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36084/ (Markdown: https://insights.sbomify.com/CVE-2022-36084/index.md)","id":"CVE-2022-36084","markdown":"https://insights.sbomify.com/CVE-2022-36084/index.md","name":"CVE-2022-36084","record":{"aliases":["GHSA-qm4w-4995-vg7f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"GraphQL API library","requires_auth":"low_privilege","summary":"Attackers with read permissions can inject arbitrary AQL queries into ArangoDB via cruddl's flexSearch feature, potentially executing code or reading data.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cruddl","vendor":"aeb"}],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-943","name":"Improper Neutralization of Special Elements in Data Query Logic"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"cruddl is software for creating a GraphQL API for a database, using the GraphQL SDL to model a schema. If cruddl starting with version 1.1.0 and prior to versions 2.7.0 and 3.0.2 is used to generate a schema that uses `@flexSearchFulltext`, users of that schema may be able to inject arbitrary AQL queries that will be forwarded to and executed by ArangoDB. Schemas that do not use `@flexSearchFulltext` are not affected. The attacker needs to have `READ` permission to at least one root entity type that has `@flexSearchFulltext` enabled. The issue has been fixed in version 3.0.2 and in version 2.7.0 of cruddl. As a workaround, users can temporarily remove `@flexSearchFulltext` from their schemas.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"cruddl vulnerable to AQL injection through flexSearch","id":"CVE-2022-36084","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":4,"n_references":3,"next":{"headline":"OPA Compiler: Bypass of WithUnsafeBuiltins using `with` keyword to mock functions","id":"CVE-2022-36085"},"packages":[{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["1.1.0"],"last_affected":[],"package":"cruddl","purl":null,"source":"GHSA-qm4w-4995-vg7f"},{"ecosystem":"npm","fixed":["2.7.0"],"introduced":["1.1.0"],"last_affected":[],"package":"cruddl","purl":"pkg:npm/cruddl","source":"GHSA-qm4w-4995-vg7f"},{"ecosystem":"npm","fixed":["3.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"cruddl","purl":null,"source":"GHSA-qm4w-4995-vg7f"},{"ecosystem":"npm","fixed":["3.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"cruddl","purl":"pkg:npm/cruddl","source":"GHSA-qm4w-4995-vg7f"}],"prev":{"headline":"JOSE vulnerable to resource exhaustion via specifically crafted JWE","id":"CVE-2022-36083"},"products":["cruddl"],"published":"2022-09-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["AEB-labs"]},"summary":"Attackers with read permissions can inject arbitrary AQL queries into ArangoDB via cruddl's flexSearch feature, potentially executing code or reading data.","url":"https://insights.sbomify.com/CVE-2022-36084/"}