CVE-2022-36087 OAuthLib vulnerable DoS when attacker provides malicious IPV6 URI
Attackers can cause denial of service in OAuthLib applications by providing malicious IPv6 URIs, affecting those using OAuth2.0 provider support or uri_validate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-36087?
CVE-2022-36087 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.
Which versions are affected by CVE-2022-36087?
3 open source packages ship an affected version, including oauthlib. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
oauthlib PyPI | From 3.1.1 | 3.2.1 |
oauthlib PyPI | From 3.1.1 | 3.2.2 |
oauthlib PyPI | From 3.1.1 | 3.2.2 |
Linux distribution packages (37)
fence-agents-aliyun AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-all AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-amt-ws AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-apc AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-apc-snmp AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-aws AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-azure-arm AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-bladecenter AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-brocade AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-cisco-mds AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-cisco-ucs AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-common AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-compute AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-drac5 AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-eaton-snmp AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-emerson AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-eps AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-gce AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-heuristics-ping AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-hpblade AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ibm-powervs AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ibm-vpc AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ibmblade AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ifmib AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ilo-moonshot AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ilo-mp AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ilo-ssh AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ilo2 AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-intelmodular AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ipdu AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-ipmilan AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-kdump AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-kubevirt AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-lpar AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-mpath AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-openstack AlmaLinux:9 | All versions | 4.10.0-43.el9 |
fence-agents-redfish AlmaLinux:9 | All versions | 4.10.0-43.el9 |
Products include Fedoraproject Fedora, Oauthlib Project Oauthlib.
How do I fix CVE-2022-36087?
Upgrade oauthlib to a fixed version for your release line: 3.2.1 or 3.2.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-36087 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36087 exists.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALSA-2023:2161, DEBIAN-CVE-2022-36087, GHSA-3pgj-pg6c-r5p7, OESA-2022-1971, PYSEC-2022-269, RHSA-2023:2161 and 4 more.