# CVE-2022-36087: OAuthLib vulnerable DoS when attacker provides malicious IPV6 URI

> Attackers can cause denial of service in OAuthLib applications by providing malicious IPv6 URIs, affecting those using OAuth2.0 provider support or uri_validate.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** ALSA-2023:2161, DEBIAN-CVE-2022-36087, GHSA-3pgj-pg6c-r5p7, OESA-2022-1971, PYSEC-2022-269, RHSA-2023:2161, UBUNTU-CVE-2022-36087, USN-5632-1, openSUSE-SU-2024:12339-1, openSUSE-SU-2025:15100-1

## What is CVE-2022-36087?

CVE-2022-36087 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-36087?

3 open source packages ship an affected version, including oauthlib. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauthlib` | PyPI | From 3.1.1 | 3.2.1 |
| `oauthlib` | PyPI | From 3.1.1 | 3.2.2 |
| `oauthlib` | PyPI | From 3.1.1 | 3.2.2 |
| `fence-agents-aliyun` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-all` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-amt-ws` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-apc` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-apc-snmp` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-aws` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-azure-arm` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-bladecenter` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-brocade` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-cisco-mds` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-cisco-ucs` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-common` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-compute` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-drac5` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-eaton-snmp` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-emerson` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-eps` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-gce` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-heuristics-ping` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-hpblade` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ibm-powervs` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ibm-vpc` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ibmblade` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ifmib` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ilo-moonshot` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ilo-mp` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ilo-ssh` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ilo2` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-intelmodular` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ipdu` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-ipmilan` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-kdump` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-kubevirt` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-lpar` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-mpath` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-openstack` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |
| `fence-agents-redfish` | AlmaLinux:9 | All versions | 4.10.0-43.el9 |

Products: Fedoraproject Fedora, Oauthlib Project Oauthlib.

## How do I fix CVE-2022-36087?

Upgrade oauthlib to a fixed version for your release line: 3.2.1 or 3.2.2.

## Is CVE-2022-36087 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36087 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36087 and fix it if it is affected.

What it is: CVE-2022-36087 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 9 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36087 exists.

Affected packages and fixed versions:
- oauthlib (PyPI): affected from 3.1.1; fixed in 3.2.1
- oauthlib (PyPI): affected from 3.1.1; fixed in 3.2.2
- oauthlib (PyPI): affected from 3.1.1; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36087/ (Markdown: https://insights.sbomify.com/CVE-2022-36087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36087
- OSV: https://osv.dev/vulnerability/CVE-2022-36087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36087/
Summaries are generated and may contain mistakes; the official description above is the record.
