CVE-2022-36090 org.xwiki.platform:xwiki-platform-oldcore Improper Authorization check for inactive users
Inactive users can bypass authorization checks to enable themselves or perform actions via REST services in XWiki Platform.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-36090?
CVE-2022-36090 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform Old Core is a core package for XWiki Platform, a generic wiki platform. Prior to versions 13.1.0.5 and 14.3-rc-1, some resources are missing a check for inactive (not yet activated or disabled) users in XWiki, including the REST service. This means a disabled user can enable themselves using a REST call. On the same way some resources handler created by extensions are not protected by default, so an inactive user could perform actions for such extensions. This issue has existed since at least version 1.1 of XWiki for instance configured with the email activation required for new users. Now it's more critical for versions 11.3-rc-1 and later since the maintainers provided the capability to disable user without deleting them and encouraged using that feature. XWiki 14.3-rc-1 and XWiki 13.10.5 contain a patch. There is no workaround for this other than upgrading XWiki.
Weakness: CWE-285
Which versions are affected by CVE-2022-36090?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 1.1 | 13.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 1.1 | 13.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 14.0 | 14.3-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 14.0 | 14.3-rc-1 |
Products include Xwiki Xwiki.
How do I fix CVE-2022-36090?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.5 or 14.3-rc-1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-36090 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36090 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-jgc8-gvcx-9vfx.