# CVE-2022-36090: org.xwiki.platform:xwiki-platform-oldcore Improper Authorization check for inactive users

> Inactive users can bypass authorization checks to enable themselves or perform actions via REST services in XWiki Platform.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-jgc8-gvcx-9vfx

## What is CVE-2022-36090?

CVE-2022-36090 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform Old Core is a core package for XWiki Platform, a generic wiki platform. Prior to versions 13.1.0.5 and 14.3-rc-1, some resources are missing a check for inactive (not yet activated or disabled) users in XWiki, including the REST service. This means a disabled user can enable themselves using a REST call. On the same way some resources handler created by extensions are not protected by default, so an inactive user could perform actions for such extensions. This issue has existed since at least version 1.1 of XWiki for instance configured with the email activation required for new users. Now it's more critical for versions 11.3-rc-1 and later since the maintainers provided the capability to disable user without deleting them and encouraged using that feature. XWiki 14.3-rc-1 and XWiki 13.10.5 contain a patch. There is no workaround for this other than upgrading XWiki.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2022-36090?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.1 | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.1 | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0 | 14.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0 | 14.3-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36090?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.5 or 14.3-rc-1.

## Is CVE-2022-36090 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36090 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36090 and fix it if it is affected.

What it is: CVE-2022-36090 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36090 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.1; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.1; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0; fixed in 14.3-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0; fixed in 14.3-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36090/ (Markdown: https://insights.sbomify.com/CVE-2022-36090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36090
- OSV: https://osv.dev/vulnerability/CVE-2022-36090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36090/
Summaries are generated and may contain mistakes; the official description above is the record.
