CVE-2022-36091 XWiki Platform Web Templates vulnerable to Missing Authorization, Exposure of Private Personal Information to Unauthorized Actor
Attackers can access private user data and sensitive configuration fields via the suggestion feature due to missing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-36091?
CVE-2022-36091 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
XWiki Platform Web Templates are templates for XWiki Platform, a generic wiki platform. Through the suggestion feature, string and list properties of objects the user shouldn't have access to can be accessed in versions prior to 13.10.4 and 14.2. This includes private personal information like email addresses and salted password hashes of registered users but also other information stored in properties of objects. Sensitive configuration fields like passwords for LDAP or SMTP servers could be accessed. By exploiting an additional vulnerability, this issue can even be exploited on private wikis at least for string properties. The issue is patched in version 13.10.4 and 14.2. Password properties are no longer displayed and rights are checked for other properties. A workaround is available. The template file `suggest.vm` can be replaced by a patched version without upgrading or restarting XWiki unless it has been overridden, in which case the overridden template should be patched, too. This might need adjustments for older versions, though.
Which versions are affected by CVE-2022-36091?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web and org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-web Maven | From 14.0 | 14.2 |
org.xwiki.platform:xwiki-platform-web Maven | From 14.0 | 14.2 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 1.3 | 13.10.4 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 1.3 | 13.10.4 |
Products include Xwiki Xwiki.
How do I fix CVE-2022-36091?
Upgrade org.xwiki.platform:xwiki-platform-web to 14.2 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-36091 being exploited?
There is no known exploitation of CVE-2022-36091 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-599v-w48h-rjrm.