# CVE-2022-36091: XWiki Platform Web Templates vulnerable to Missing Authorization, Exposure of Private Personal Information to Unauthorized Actor

> Attackers can access private user data and sensitive configuration fields via the suggestion feature due to missing authorization checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-599v-w48h-rjrm

## What is CVE-2022-36091?

CVE-2022-36091 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform Web Templates are templates for XWiki Platform, a generic wiki platform. Through the suggestion feature, string and list properties of objects the user shouldn't have access to can be accessed in versions prior to 13.10.4 and 14.2. This includes private personal information like email addresses and salted password hashes of registered users but also other information stored in properties of objects. Sensitive configuration fields like passwords for LDAP or SMTP servers could be accessed. By exploiting an additional vulnerability, this issue can even be exploited on private wikis at least for string properties. The issue is patched in version 13.10.4 and 14.2. Password properties are no longer displayed and rights are checked for other properties. A workaround is available. The template file `suggest.vm` can be replaced by a patched version without upgrading or restarting XWiki unless it has been overridden, in which case the overridden template should be patched, too. This might need adjustments for older versions, though.

Weakness: CWE-862 (Missing Authorization), CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-36091?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web and org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.0 | 14.2 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.0 | 14.2 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 1.3 | 13.10.4 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 1.3 | 13.10.4 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36091?

Upgrade org.xwiki.platform:xwiki-platform-web to 14.2 or later.

## Is CVE-2022-36091 being exploited?

There is no known exploitation of CVE-2022-36091 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36091 and fix it if it is affected.

What it is: CVE-2022-36091 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36091 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.0; fixed in 14.2
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.0; fixed in 14.2
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 1.3; fixed in 13.10.4
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 1.3; fixed in 13.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36091/ (Markdown: https://insights.sbomify.com/CVE-2022-36091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36091
- OSV: https://osv.dev/vulnerability/CVE-2022-36091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36091/
Summaries are generated and may contain mistakes; the official description above is the record.
