# CVE-2022-36092: XWiki Platform Old Core vulnerable to Authentication Bypass Using the Login Action

> Attackers can bypass view rights to read titles, content, and comments of any document, including private wikis, by exploiting the login action.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8h89-34w2-jpfm

## What is CVE-2022-36092?

CVE-2022-36092 is a high-severity authentication bypass vulnerability in Xwiki Xwiki, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform Old Core is a core package for XWiki Platform, a generic wiki platform. Prior to versions 14.2 and 13.10.4, all rights checks that would normally prevent a user from viewing a document on a wiki can be bypassed using the login action and directly specified templates. This exposes title, content and comments of any document and properties of objects, though class and property name must be known. This is also exploitable on private wikis. This has been patched in versions 14.2 and 13.10.4 by properly checking view rights before loading documents and disallowing non-default templates in the login, registration and skin action. As a workaround, it would be possible to protect all templates individually by adding code to check access rights first.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-36092?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 13.10.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 13.10.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0 | 14.2 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0 | 14.2 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36092?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.4 or 14.2.

## Is CVE-2022-36092 being exploited?

There is no known exploitation of CVE-2022-36092 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36092 and fix it if it is affected.

What it is: CVE-2022-36092 is a high-severity authentication bypass vulnerability in Xwiki Xwiki, published on 8 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36092 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 13.10.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 13.10.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0; fixed in 14.2
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0; fixed in 14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36092/ (Markdown: https://insights.sbomify.com/CVE-2022-36092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36092
- OSV: https://osv.dev/vulnerability/CVE-2022-36092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36092/
Summaries are generated and may contain mistakes; the official description above is the record.
