# CVE-2022-36093: XWiki Platform Web Templates vulnerable to Unauthorized User Registration Through the Distribution Wizard

> Attackers can create unauthorized user accounts bypassing registration restrictions and email verification, potentially gaining write access to private or read-only wikis.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-h5j3-5x63-p8jv

## What is CVE-2022-36093?

CVE-2022-36093 is a high-severity authentication bypass vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform Web Templates are templates for XWiki Platform, a generic wiki platform. By passing a template of the distribution wizard to the xpart template, user accounts can be created even when user registration is disabled. This also circumvents any email verification. Before versions 14.2 and 13.10.4, this can also be exploited on a private wiki, thus potentially giving the attacker access to the wiki. Depending on the configured default rights of users, this could also give attackers write access to an otherwise read-only public wiki. Users can also be created when an external authentication system like LDAP is configured, but authentication fails unless the authentication system supports a bypass/local accounts are enabled in addition to the external authentication system. This issue has been patched in XWiki 13.10.5 and 14.3RC1. As a workaround, one may replace `xpart.vm`, the entry point for this attack, by a patched version from the patch without updating XWiki.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-36093?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web and org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.0 | 14.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.0 | 14.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 8.0-rc-1 | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 8.0-rc-1 | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | All versions | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | All versions | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 14.0 | 14.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 14.0 | 14.3-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36093?

Upgrade org.xwiki.platform:xwiki-platform-web to a fixed version for your release line: 14.3-rc-1 or 13.10.5.

## Is CVE-2022-36093 being exploited?

There is no known exploitation of CVE-2022-36093 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36093 and fix it if it is affected.

What it is: CVE-2022-36093 is a high-severity authentication bypass vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36093 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.0; fixed in 14.3-rc-1
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.0; fixed in 14.3-rc-1
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 8.0-rc-1; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 8.0-rc-1; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected all versions; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected all versions; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 14.0; fixed in 14.3-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 14.0; fixed in 14.3-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36093/ (Markdown: https://insights.sbomify.com/CVE-2022-36093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36093
- OSV: https://osv.dev/vulnerability/CVE-2022-36093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36093/
Summaries are generated and may contain mistakes; the official description above is the record.
