CVE-2022-36096 XWiki Platform vulnerable to Cross-site Scripting in the deleted attachments list
Attackers can execute arbitrary JavaScript in victims' browsers by uploading attachments with malicious names, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-36096?
CVE-2022-36096 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and attachments for XWiki Platform, a generic wiki platform. Prior to versions 13.10.6 and 14.3, it's possible to store JavaScript which will be executed by anyone viewing the deleted attachments index with an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3. As a workaround, modify fix the vulnerability by editing the wiki page `XWiki.DeletedAttachments` with the object editor, open the `JavaScriptExtension` object and apply on the content the changes that can be found on the fix commit.
Which versions are affected by CVE-2022-36096?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-index-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-index-ui Maven | From 14.0 | 14.3 |
org.xwiki.platform:xwiki-platform-index-ui Maven | From 14.0 | 14.3 |
org.xwiki.platform:xwiki-platform-index-ui Maven | From 2.2-milestone-1 | 13.10.6 |
org.xwiki.platform:xwiki-platform-index-ui Maven | From 2.2-milestone-1 | 13.10.6 |
Products include Xwiki Xwiki.
How do I fix CVE-2022-36096?
Upgrade org.xwiki.platform:xwiki-platform-index-ui to a fixed version for your release line: 14.3 or 13.10.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-36096 being exploited?
There is no known exploitation of CVE-2022-36096 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-gjmq-x5x7-wc36.