# CVE-2022-36096: XWiki Platform vulnerable to Cross-site Scripting in the deleted attachments list

> Attackers can execute arbitrary JavaScript in victims' browsers by uploading attachments with malicious names, potentially leading to session hijacking or data theft.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-gjmq-x5x7-wc36

## What is CVE-2022-36096?

CVE-2022-36096 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and attachments for XWiki Platform, a generic wiki platform. Prior to versions 13.10.6 and 14.3, it's possible to store JavaScript which will be executed by anyone viewing the deleted attachments index with an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3. As a workaround, modify fix the vulnerability by editing the wiki page `XWiki.DeletedAttachments` with the object editor, open the `JavaScriptExtension` object and apply on the content the changes that can be found on the fix commit.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-36096?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-index-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-index-ui` | Maven | From 14.0 | 14.3 |
| `org.xwiki.platform:xwiki-platform-index-ui` | Maven | From 14.0 | 14.3 |
| `org.xwiki.platform:xwiki-platform-index-ui` | Maven | From 2.2-milestone-1 | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-index-ui` | Maven | From 2.2-milestone-1 | 13.10.6 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36096?

Upgrade org.xwiki.platform:xwiki-platform-index-ui to a fixed version for your release line: 14.3 or 13.10.6.

## Is CVE-2022-36096 being exploited?

There is no known exploitation of CVE-2022-36096 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36096 and fix it if it is affected.

What it is: CVE-2022-36096 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36096 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-index-ui (Maven): affected from 14.0; fixed in 14.3
- org.xwiki.platform:xwiki-platform-index-ui (Maven): affected from 14.0; fixed in 14.3
- org.xwiki.platform:xwiki-platform-index-ui (Maven): affected from 2.2-milestone-1; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-index-ui (Maven): affected from 2.2-milestone-1; fixed in 13.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36096/ (Markdown: https://insights.sbomify.com/CVE-2022-36096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36096
- OSV: https://osv.dev/vulnerability/CVE-2022-36096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36096/
Summaries are generated and may contain mistakes; the official description above is the record.
