# CVE-2022-36097: XWiki Platform Attachment UI vulnerable to cross-site scripting in the move attachment form

> Attackers can inject JavaScript via attachment names, leading to script execution when users attempt to move attachments in XWiki.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-9r9j-57rf-f6vj

## What is CVE-2022-36097?

CVE-2022-36097 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform Attachment UI provides a macro to easily upload and select attachments for XWiki Platform, a generic wiki platform. Starting with version 14.0-rc-1 and prior to 14.4-rc-1, it's possible to store JavaScript in an attachment name, which will be executed by anyone trying to move the corresponding attachment. This issue has been patched in XWiki 14.4-rc-1. As a workaround, one may copy `moveStep1.vm` to `webapp/xwiki/templates/moveStep1.vm` and replace vulnerable code with code from the patch.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-36097?

2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-attachment-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-attachment-ui` | Maven | From 14.0-rc-1 | 14.4-rc-1 |
| `org.xwiki.platform:xwiki-platform-attachment-ui` | Maven | From 14.0-rc-1 | 14.4-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36097?

Upgrade org.xwiki.platform:xwiki-platform-attachment-ui to 14.4-rc-1 or later.

## Is CVE-2022-36097 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36097 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36097 and fix it if it is affected.

What it is: CVE-2022-36097 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36097 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-attachment-ui (Maven): affected from 14.0-rc-1; fixed in 14.4-rc-1
- org.xwiki.platform:xwiki-platform-attachment-ui (Maven): affected from 14.0-rc-1; fixed in 14.4-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36097/ (Markdown: https://insights.sbomify.com/CVE-2022-36097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36097
- OSV: https://osv.dev/vulnerability/CVE-2022-36097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36097/
Summaries are generated and may contain mistakes; the official description above is the record.
