CVE-2022-36098 XWiki Platform Mentions UI vulnerable to Cross-site Scripting
Attackers can inject malicious scripts into XWiki mentions, leading to code execution or account takeover for visiting users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-36098?
CVE-2022-36098 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
XWiki Platform Mentions UI is a user interface for mentioning users in wiki content for XWiki Platform, a generic wiki platform. Starting in version 12.5-rc-1 and prior to versions 13.10.6 and 14.4, it's possible to store Javascript or groovy scripts in a mention, macro anchor, or reference field. The stored code is executed by anyone visiting the page with the mention. This issue has been patched on XWiki 14.4 and 13.10.6. As a workaround, one may update `XWiki.Mentions.MentionsMacro` and edit the `Macro code` field of the `XWiki.WikiMacroClass` XObject.
Weakness: CWE-79
Which versions are affected by CVE-2022-36098?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-mentions-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-mentions-ui Maven | From 12.5-rc-1 | 13.10.6 |
org.xwiki.platform:xwiki-platform-mentions-ui Maven | From 12.5-rc-1 | 13.10.6 |
org.xwiki.platform:xwiki-platform-mentions-ui Maven | From 14.0 | 14.4 |
org.xwiki.platform:xwiki-platform-mentions-ui Maven | From 14.0 | 14.4 |
Products include Xwiki Xwiki.
How do I fix CVE-2022-36098?
Upgrade org.xwiki.platform:xwiki-platform-mentions-ui to a fixed version for your release line: 13.10.6 or 14.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-36098 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36098 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-c5v8-2q4r-5w9v.