# CVE-2022-36098: XWiki Platform Mentions UI vulnerable to Cross-site Scripting

> Attackers can inject malicious scripts into XWiki mentions, leading to code execution or account takeover for visiting users.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-c5v8-2q4r-5w9v

## What is CVE-2022-36098?

CVE-2022-36098 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform Mentions UI is a user interface for mentioning users in wiki content for XWiki Platform, a generic wiki platform. Starting in version 12.5-rc-1 and prior to versions 13.10.6 and 14.4, it's possible to store Javascript or groovy scripts in a mention, macro anchor, or reference field. The stored code is executed by anyone visiting the page with the mention. This issue has been patched on XWiki 14.4 and 13.10.6. As a workaround, one may update `XWiki.Mentions.MentionsMacro` and edit the `Macro code` field of the `XWiki.WikiMacroClass` XObject.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-36098?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-mentions-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-mentions-ui` | Maven | From 12.5-rc-1 | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-mentions-ui` | Maven | From 12.5-rc-1 | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-mentions-ui` | Maven | From 14.0 | 14.4 |
| `org.xwiki.platform:xwiki-platform-mentions-ui` | Maven | From 14.0 | 14.4 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36098?

Upgrade org.xwiki.platform:xwiki-platform-mentions-ui to a fixed version for your release line: 13.10.6 or 14.4.

## Is CVE-2022-36098 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36098 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36098 and fix it if it is affected.

What it is: CVE-2022-36098 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36098 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-mentions-ui (Maven): affected from 12.5-rc-1; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-mentions-ui (Maven): affected from 12.5-rc-1; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-mentions-ui (Maven): affected from 14.0; fixed in 14.4
- org.xwiki.platform:xwiki-platform-mentions-ui (Maven): affected from 14.0; fixed in 14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36098/ (Markdown: https://insights.sbomify.com/CVE-2022-36098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36098
- OSV: https://osv.dev/vulnerability/CVE-2022-36098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36098/
Summaries are generated and may contain mistakes; the official description above is the record.
