# CVE-2022-36099: XWiki Platform Wiki UI Main Wiki Eval Injection vulnerability

> Attackers with view access can inject scripts via URL parameters to execute arbitrary code, bypassing rights checks and compromising data integrity and availability.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-xr6m-2p4m-jvqf

## What is CVE-2022-36099?

CVE-2022-36099 is a critical code injection vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform Wiki UI Main Wiki is software for managing subwikis on XWiki Platform, a generic wiki platform. Starting with version 5.3-milestone-2 and prior to versions 13.10.6 and 14.4, it's possible to inject arbitrary wiki syntax including Groovy, Python and Velocity script macros via the request (URL parameter) using the `XWikiServerClassSheet` if the user has view access to this sheet and another page that has been saved with programming rights, a standard condition on a public read-only XWiki installation or a private XWiki installation where the user has an account. This allows arbitrary Groovy/Python/Velocity code execution which allows bypassing all rights checks and thus both modification and disclosure of all content stored in the XWiki installation. Also, this could be used to impact the availability of the wiki. This has been patched in versions 13.10.6 and 14.4. As a workaround, edit the affected document `XWiki.XWikiServerClassSheet` or `WikiManager.XWikiServerClassSheet` and manually perform the changes from the patch fixing the issue. On XWiki versions 12.0 and later, it is also possible to import the document `XWiki.XWikiServerClassSheet` from the xwiki-platform-wiki-ui-mainwiki package version 14.4 using the import feature of the administration application as there have been no other changes to this document since XWiki 12.0.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-36099?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki` | Maven | From 14.0 | 14.4 |
| `org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki` | Maven | From 14.0 | 14.4 |
| `org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki` | Maven | From 5.3-milestone-2 | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki` | Maven | From 5.3-milestone-2 | 13.10.6 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36099?

Upgrade org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki to a fixed version for your release line: 14.4 or 13.10.6.

## Is CVE-2022-36099 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36099 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36099 and fix it if it is affected.

What it is: CVE-2022-36099 is a critical code injection vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36099 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki (Maven): affected from 14.0; fixed in 14.4
- org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki (Maven): affected from 14.0; fixed in 14.4
- org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki (Maven): affected from 5.3-milestone-2; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-wiki-ui-mainwiki (Maven): affected from 5.3-milestone-2; fixed in 13.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36099/ (Markdown: https://insights.sbomify.com/CVE-2022-36099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36099
- OSV: https://osv.dev/vulnerability/CVE-2022-36099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36099/
Summaries are generated and may contain mistakes; the official description above is the record.
