# CVE-2022-36100: XWiki Platform Applications Tag and XWiki Platform Tag UI vulnerable to Eval Injection

> Attackers can execute arbitrary code and bypass security controls in XWiki due to improper input sanitization in tag applications, affecting public or authenticated users.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-2g5c-228j-p52x

## What is CVE-2022-36100?

CVE-2022-36100 is a critical code injection vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform Applications Tag and XWiki Platform Tag UI are tag applications for XWiki, a generic wiki platform. Starting with version 1.7 in XWiki Platform Applications Tag and prior to 13.10.6 and 14.4 in XWiki Platform Tag UI, the tags document `Main.Tags` in XWiki didn't sanitize user inputs properly. This allowed users with view rights on the document (default in a public wiki or for authenticated users on private wikis) to execute arbitrary Groovy, Python and Velocity code with programming rights. This also allowed bypassing all rights checks and thus both modification and disclosure of all content stored in the XWiki installation. The vulnerability could be used to impact the availability of the wiki. On XWiki versions before 13.10.4 and 14.2, this can be combined with CVE-2022-36092, meaning that no rights are required to perform the attack. The vulnerability has been patched in versions 13.10.6 and 14.4. As a workaround, the patch that fixes the issue can be manually applied to the document `Main.Tags` or the updated version of that document can be imported from version 14.4 of xwiki-platform-tag-ui using the import feature in the administration UI on XWiki 10.9 and later.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-36100?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-tag-ui and org.xwiki.platform.applications:xwiki-application-tag. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | All versions | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | All versions | 13.10.6 |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | From 14.0 | 14.4 |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | From 14.0 | 14.4 |
| `org.xwiki.platform.applications:xwiki-application-tag` | Maven | From 1.7 | None |
| `org.xwiki.platform.applications:xwiki-application-tag` | Maven | From 1.7 | None |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-36100?

Upgrade org.xwiki.platform:xwiki-platform-tag-ui to a fixed version for your release line: 13.10.6 or 14.4.

## Is CVE-2022-36100 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36100 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36100 and fix it if it is affected.

What it is: CVE-2022-36100 is a critical code injection vulnerability in Xwiki Xwiki, published on 8 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36100 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected all versions; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected all versions; fixed in 13.10.6
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected from 14.0; fixed in 14.4
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected from 14.0; fixed in 14.4
- org.xwiki.platform.applications:xwiki-application-tag (Maven): affected from 1.7; no fix listed
- org.xwiki.platform.applications:xwiki-application-tag (Maven): affected from 1.7; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36100/ (Markdown: https://insights.sbomify.com/CVE-2022-36100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36100
- OSV: https://osv.dev/vulnerability/CVE-2022-36100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36100/
Summaries are generated and may contain mistakes; the official description above is the record.
