# CVE-2022-36101: Sensitive data in backend customer module

> Attackers can access sensitive customer data, including hashed passwords and session IDs, via the backend administration interface.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6vfq-jmxg-g58r

## What is CVE-2022-36101?

CVE-2022-36101 is a medium-severity vulnerability in Shopware Shopware, published on 12 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware is an open source e-commerce software. In affected versions the request for the customer detail view in the backend administration contained sensitive data like the hashed password and the session ID. These fields are now explicitly unset in version 5.7.15. Users are advised to update and may get the update either via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-36101?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | All versions | 5.7.15 |
| `shopware/shopware` | Packagist | All versions | 5.7.15 |

Products: Shopware Shopware.

## How do I fix CVE-2022-36101?

Upgrade shopware/shopware to 5.7.15 or later.

## Is CVE-2022-36101 being exploited?

There is no known exploitation of CVE-2022-36101 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36101 and fix it if it is affected.

What it is: CVE-2022-36101 is a medium-severity vulnerability in Shopware Shopware, published on 12 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36101 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected all versions; fixed in 5.7.15
- shopware/shopware (Packagist): affected all versions; fixed in 5.7.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36101/ (Markdown: https://insights.sbomify.com/CVE-2022-36101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36101
- OSV: https://osv.dev/vulnerability/CVE-2022-36101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36101/
Summaries are generated and may contain mistakes; the official description above is the record.
