{"answers":{"affected":"3 open source packages ship an affected version, including github.com/gravitl/netmaker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36110 in the wild and no public exploit code.","fix":"Upgrade github.com/gravitl/netmaker to 0.15.1 or later.","what":"CVE-2022-36110 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 9 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36110 and fix it if it is affected.\n\nWhat it is: CVE-2022-36110 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 9 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.15.1\n- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.15.1\n- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.15.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36110/ (Markdown: https://insights.sbomify.com/CVE-2022-36110/index.md)","id":"CVE-2022-36110","markdown":"https://insights.sbomify.com/CVE-2022-36110/index.md","name":"CVE-2022-36110","record":{"aliases":["GHSA-ggf6-638m-vqmg","GO-2022-0986"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Netmaker network platform","requires_auth":"low_privilege","summary":"Non-privileged users can execute admin-level API calls due to improper authorization checks, allowing privilege escalation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"netmaker","vendor":"netmaker"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-1220","name":"Insufficient Granularity of Access Control"}],"description":"Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Netmaker vulnerable to Insufficient Granularity of Access Control","id":"CVE-2022-36110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"immundb has insufficient verification of data authenticity","id":"CVE-2022-36111"},"packages":[{"ecosystem":"Go","fixed":["0.15.1"],"introduced":["0"],"last_affected":[],"package":"github.com/gravitl/netmaker","purl":null,"source":"GHSA-ggf6-638m-vqmg"},{"ecosystem":"Go","fixed":["0.15.1"],"introduced":["0"],"last_affected":[],"package":"github.com/gravitl/netmaker","purl":"pkg:golang/github.com/gravitl/netmaker","source":"GHSA-ggf6-638m-vqmg"},{"ecosystem":"Go","fixed":["0.15.1"],"introduced":["0"],"last_affected":[],"package":"github.com/gravitl/netmaker","purl":"pkg:golang/github.com/gravitl/netmaker","source":"GO-2022-0986"}],"prev":{"headline":"Moby vulnerability relating to supplementary group permissions","id":"CVE-2022-36109"},"products":["netmaker"],"published":"2022-09-09","related":[{"cvss_score":8.8,"headline":"Netmaker Privilige Escalation Vulnerability","id":"CVE-2023-32079","kev_date_added":null,"published":"2023-08-24"},{"cvss_score":8.8,"headline":"Use of Hard-coded Cryptographic Key in gravitl/netmaker","id":"CVE-2022-0664","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":8.7,"headline":"Netmaker: Denial of Service via Server Shutdown Endpoint","id":"CVE-2026-29771","kev_date_added":null,"published":"2026-03-07"},{"cvss_score":8.2,"headline":"Netmaker does not verify JWT signatures for host tokens","id":"CVE-2026-38651","kev_date_added":null,"published":"2026-04-28"},{"cvss_score":7.5,"headline":"Netmaker has Hardcoded DNS Secret Key","id":"CVE-2023-32077","kev_date_added":null,"published":"2023-08-24"},{"cvss_score":7.5,"headline":"Netmaker IDOR Vulnerability Allows User to Update Other User's Password","id":"CVE-2023-32078","kev_date_added":null,"published":"2023-08-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["gravitl"]},"summary":"Non-privileged users can execute admin-level API calls due to improper authorization checks, allowing privilege escalation.","url":"https://insights.sbomify.com/CVE-2022-36110/"}