# CVE-2022-36110: Netmaker vulnerable to Insufficient Granularity of Access Control

> Non-privileged users can execute admin-level API calls due to improper authorization checks, allowing privilege escalation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-ggf6-638m-vqmg, GO-2022-0986

## What is CVE-2022-36110?

CVE-2022-36110 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 9 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

Weakness: CWE-285 (Improper Authorization), CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2022-36110?

3 open source packages ship an affected version, including github.com/gravitl/netmaker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gravitl/netmaker` | Go | All versions | 0.15.1 |
| `github.com/gravitl/netmaker` | Go | All versions | 0.15.1 |
| `github.com/gravitl/netmaker` | Go | All versions | 0.15.1 |

Products: Netmaker Netmaker.

## How do I fix CVE-2022-36110?

Upgrade github.com/gravitl/netmaker to 0.15.1 or later.

## Is CVE-2022-36110 being exploited?

There is no known exploitation of CVE-2022-36110 in the wild and no public exploit code.

## Other vulnerabilities in gravitl netmaker

- [CVE-2023-32079](https://insights.sbomify.com/CVE-2023-32079/): Netmaker Privilige Escalation Vulnerability (high 8.8)
- [CVE-2022-0664](https://insights.sbomify.com/CVE-2022-0664/): Use of Hard-coded Cryptographic Key in gravitl/netmaker (high 8.8)
- [CVE-2026-29771](https://insights.sbomify.com/CVE-2026-29771/): Netmaker: Denial of Service via Server Shutdown Endpoint (high 8.7)
- [CVE-2026-38651](https://insights.sbomify.com/CVE-2026-38651/): Netmaker does not verify JWT signatures for host tokens (high 8.2)
- [CVE-2023-32077](https://insights.sbomify.com/CVE-2023-32077/): Netmaker has Hardcoded DNS Secret Key (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36110 and fix it if it is affected.

What it is: CVE-2022-36110 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 9 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36110 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.15.1
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.15.1
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36110/ (Markdown: https://insights.sbomify.com/CVE-2022-36110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36110
- OSV: https://osv.dev/vulnerability/CVE-2022-36110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36110/
Summaries are generated and may contain mistakes; the official description above is the record.
