{"answers":{"affected":"3 open source packages ship an affected version, including github.com/codenotary/immudb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36111 exists.","fix":"Upgrade github.com/codenotary/immudb to 1.4.1 or later.","what":"CVE-2022-36111 is a medium-severity vulnerability in codenotary immudb, published on 23 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-36111 and fix it if it is affected.\n\nWhat it is: CVE-2022-36111 is a medium-severity vulnerability in codenotary immudb, published on 23 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36111 exists.\n\nAffected packages and fixed versions:\n- github.com/codenotary/immudb (Go): affected all versions; fixed in 1.4.1\n- github.com/codenotary/immudb (Go): affected all versions; fixed in 1.4.1\n- github.com/codenotary/immudb (Go): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36111/ (Markdown: https://insights.sbomify.com/CVE-2022-36111/index.md)","id":"CVE-2022-36111","markdown":"https://insights.sbomify.com/CVE-2022-36111/index.md","name":"CVE-2022-36111","record":{"aliases":["GHSA-672p-m5jq-mrh8","GO-2022-1117"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"immudb client SDK","requires_auth":"high_privilege","summary":"A malicious server can trick the immudb client SDK into accepting falsified proofs, allowing transaction replacement and bypassing cryptographic verification.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"immudb","vendor":"codenotary"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"immudb is a database with built-in cryptographic proof and verification. In versions prior to 1.4.1, a malicious immudb server can provide a falsified proof that will be accepted by the client SDK signing a falsified transaction replacing the genuine one. This situation can not be triggered by a genuine immudb server and requires the client to perform a specific list of verified operations resulting in acceptance of an invalid state value. This vulnerability only affects immudb client SDKs, the immudb server itself is not affected by this vulnerability. This issue has been patched in version 1.4.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"immundb has insufficient verification of data authenticity","id":"CVE-2022-36111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"other","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Blind Server-Side Request Forgery (SSRF) in GLPI","id":"CVE-2022-36112"},"packages":[{"ecosystem":"Go","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"github.com/codenotary/immudb","purl":null,"source":"GHSA-672p-m5jq-mrh8"},{"ecosystem":"Go","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"github.com/codenotary/immudb","purl":"pkg:golang/github.com/codenotary/immudb","source":"GHSA-672p-m5jq-mrh8"},{"ecosystem":"Go","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"github.com/codenotary/immudb","purl":"pkg:golang/github.com/codenotary/immudb","source":"GO-2022-1117"}],"prev":{"headline":"Netmaker vulnerable to Insufficient Granularity of Access Control","id":"CVE-2022-36110"},"products":["immudb"],"published":"2022-11-23","related":[{"cvss_score":7.4,"headline":"Information disclosure in n/a","id":"CVE-2024-41262","kev_date_added":null,"published":"2024-07-31"},{"cvss_score":5.8,"headline":"Lack of proper validation in immudb","id":"CVE-2022-39199","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["codenotary"]},"summary":"A malicious server can trick the immudb client SDK into accepting falsified proofs, allowing transaction replacement and bypassing cryptographic verification.","url":"https://insights.sbomify.com/CVE-2022-36111/"}