# CVE-2022-36111: immundb has insufficient verification of data authenticity

> A malicious server can trick the immudb client SDK into accepting falsified proofs, allowing transaction replacement and bypassing cryptographic verification.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-672p-m5jq-mrh8, GO-2022-1117

## What is CVE-2022-36111?

CVE-2022-36111 is a medium-severity vulnerability in codenotary immudb, published on 23 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

immudb is a database with built-in cryptographic proof and verification. In versions prior to 1.4.1, a malicious immudb server can provide a falsified proof that will be accepted by the client SDK signing a falsified transaction replacing the genuine one. This situation can not be triggered by a genuine immudb server and requires the client to perform a specific list of verified operations resulting in acceptance of an invalid state value. This vulnerability only affects immudb client SDKs, the immudb server itself is not affected by this vulnerability. This issue has been patched in version 1.4.1.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2022-36111?

3 open source packages ship an affected version, including github.com/codenotary/immudb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/codenotary/immudb` | Go | All versions | 1.4.1 |
| `github.com/codenotary/immudb` | Go | All versions | 1.4.1 |
| `github.com/codenotary/immudb` | Go | All versions | 1.4.1 |

Products: Codenotary Immudb.

## How do I fix CVE-2022-36111?

Upgrade github.com/codenotary/immudb to 1.4.1 or later.

## Is CVE-2022-36111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36111 exists.

## Other vulnerabilities in codenotary immudb

- [CVE-2024-41262](https://insights.sbomify.com/CVE-2024-41262/): Information disclosure in n/a (high 7.4)
- [CVE-2022-39199](https://insights.sbomify.com/CVE-2022-39199/): Lack of proper validation in immudb (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36111 and fix it if it is affected.

What it is: CVE-2022-36111 is a medium-severity vulnerability in codenotary immudb, published on 23 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36111 exists.

Affected packages and fixed versions:
- github.com/codenotary/immudb (Go): affected all versions; fixed in 1.4.1
- github.com/codenotary/immudb (Go): affected all versions; fixed in 1.4.1
- github.com/codenotary/immudb (Go): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36111/ (Markdown: https://insights.sbomify.com/CVE-2022-36111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36111
- OSV: https://osv.dev/vulnerability/CVE-2022-36111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36111/
Summaries are generated and may contain mistakes; the official description above is the record.
