# CVE-2022-36124: Memory overconsumption in Avro Rust SDK

> Attackers can cause memory exhaustion in Rust applications using Apache Avro, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2022
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-wcm8-86x6-8mv3, PYSEC-2022-43180

## What is CVE-2022-36124?

CVE-2022-36124 is a high-severity denial of service vulnerability in Apache Avro, published on 9 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It is possible for a Reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-36124?

3 open source packages ship an affected version, including apache-avro and avro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-avro` | crates.io | All versions | 0.14.0 |
| `apache-avro` | crates.io | All versions | 0.14.0 |
| `avro` | PyPI | All versions | None |

Products: Apache Avro.

## How do I fix CVE-2022-36124?

Upgrade apache-avro to 0.14.0 or later.

## Is CVE-2022-36124 being exploited?

There is no known exploitation of CVE-2022-36124 in the wild and no public exploit code.

## Other vulnerabilities in Apache Avro

- [CVE-2024-47561](https://insights.sbomify.com/CVE-2024-47561/): Apache Avro Java SDK: Arbitrary Code Execution when reading Avro schema (Java SDK) (critical 9.2)
- [CVE-2023-39410](https://insights.sbomify.com/CVE-2023-39410/): Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK (high 7.5)
- [CVE-2022-35724](https://insights.sbomify.com/CVE-2022-35724/): Denial of service while reading data in Avro Rust SDK (high 7.5)
- [CVE-2022-36125](https://insights.sbomify.com/CVE-2022-36125/): Integer overflow when reading corrupted .avro file in Avro Rust SDK (high 7.5)
- [CVE-2021-43045](https://insights.sbomify.com/CVE-2021-43045/): Possible DOS vulnerabilities in C# Avro SDK (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36124 and fix it if it is affected.

What it is: CVE-2022-36124 is a high-severity denial of service vulnerability in Apache Avro, published on 9 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36124 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-avro (crates.io): affected all versions; fixed in 0.14.0
- apache-avro (crates.io): affected all versions; fixed in 0.14.0
- avro (PyPI): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36124/ (Markdown: https://insights.sbomify.com/CVE-2022-36124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36124
- OSV: https://osv.dev/vulnerability/CVE-2022-36124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36124/
Summaries are generated and may contain mistakes; the official description above is the record.
