{"answers":{"affected":"2 open source packages ship an affected version, including apache-avro. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36125 in the wild and no public exploit code.","fix":"Upgrade apache-avro to 0.14.0 or later.","what":"CVE-2022-36125 is a high-severity vulnerability in Apache Avro, published on 9 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36125 and fix it if it is affected.\n\nWhat it is: CVE-2022-36125 is a high-severity vulnerability in Apache Avro, published on 9 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36125 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-avro (crates.io): affected all versions; fixed in 0.14.0\n- apache-avro (crates.io): affected all versions; fixed in 0.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36125/ (Markdown: https://insights.sbomify.com/CVE-2022-36125/index.md)","id":"CVE-2022-36125","markdown":"https://insights.sbomify.com/CVE-2022-36125/index.md","name":"CVE-2022-36125","record":{"aliases":["GHSA-3w5g-989p-35r8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Avro Rust SDK","requires_auth":"none","summary":"An attacker can crash Rust applications using the Apache Avro library by providing a corrupted .avro file, causing a panic via integer overflow.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"avro","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"It is possible to crash (panic) an application by providing a corrupted data to be read. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow when reading corrupted .avro file in Avro Rust SDK","id":"CVE-2022-36125","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"integer_overflow","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Code injection in n/a","id":"CVE-2022-36126"},"packages":[{"ecosystem":"crates.io","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"apache-avro","purl":null,"source":"GHSA-3w5g-989p-35r8"},{"ecosystem":"crates.io","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"apache-avro","purl":"pkg:cargo/apache-avro","source":"GHSA-3w5g-989p-35r8"}],"prev":{"headline":"Memory overconsumption in Avro Rust SDK","id":"CVE-2022-36124"},"products":["Apache Avro"],"published":"2022-08-09","related":[{"cvss_score":9.2,"headline":"Apache Avro Java SDK: Arbitrary Code Execution when reading Avro schema (Java SDK)","id":"CVE-2024-47561","kev_date_added":null,"published":"2024-10-03"},{"cvss_score":7.5,"headline":"Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK","id":"CVE-2023-39410","kev_date_added":null,"published":"2023-09-29"},{"cvss_score":7.5,"headline":"Denial of service while reading data in Avro Rust SDK","id":"CVE-2022-35724","kev_date_added":null,"published":"2022-08-09"},{"cvss_score":7.5,"headline":"Memory overconsumption in Avro Rust SDK","id":"CVE-2022-36124","kev_date_added":null,"published":"2022-08-09"},{"cvss_score":7.5,"headline":"Possible DOS vulnerabilities in C# Avro SDK","id":"CVE-2021-43045","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":7.3,"headline":"Apache Avro Java SDK: Code injection on Java generated code","id":"CVE-2025-33042","kev_date_added":null,"published":"2026-02-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-06","vendors":["Apache Software Foundation"]},"summary":"An attacker can crash Rust applications using the Apache Avro library by providing a corrupted .avro file, causing a panic via integer overflow.","url":"https://insights.sbomify.com/CVE-2022-36125/"}