CVE-2022-36127 Service unavailability impact in NodeJS agent(version <= 0.5.0)

High 7.5 Published Updated

An attacker or network issue causing OAP unavailability can render NodeJS services unavailable due to connection handling flaws in the SkyWalking agent.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-36127?

CVE-2022-36127 is a high-severity denial of service vulnerability in Apache SkyWalking NodeJS Agent, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability in Apache SkyWalking NodeJS Agent prior to 0.5.1. The vulnerability will cause NodeJS services that has this agent installed to be unavailable if the OAP is unhealthy and NodeJS agent can't establish the connection.

Which versions are affected by CVE-2022-36127?

2 open source packages ship an affected version, including skywalking-backend-js. It affects 1 product.

PackageAffectedFixed in
skywalking-backend-js npmAll versions0.5.1
skywalking-backend-js npmAll versions0.5.1

Products include Apache Skywalking Nodejs Agent.

How do I fix CVE-2022-36127?

Upgrade skywalking-backend-js to 0.5.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-36127 being exploited?

There is no known exploitation of CVE-2022-36127 in the wild and no public exploit code.

Sources

Also known as GHSA-8gpg-466c-5cpj.

Is CVE-2022-36127 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free