{"answers":{"affected":"2 open source packages ship an affected version, including skywalking-backend-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36127 in the wild and no public exploit code.","fix":"Upgrade skywalking-backend-js to 0.5.1 or later.","what":"CVE-2022-36127 is a high-severity denial of service vulnerability in Apache SkyWalking NodeJS Agent, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36127 and fix it if it is affected.\n\nWhat it is: CVE-2022-36127 is a high-severity denial of service vulnerability in Apache SkyWalking NodeJS Agent, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36127 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- skywalking-backend-js (npm): affected all versions; fixed in 0.5.1\n- skywalking-backend-js (npm): affected all versions; fixed in 0.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36127/ (Markdown: https://insights.sbomify.com/CVE-2022-36127/index.md)","id":"CVE-2022-36127","markdown":"https://insights.sbomify.com/CVE-2022-36127/index.md","name":"CVE-2022-36127","record":{"aliases":["GHSA-8gpg-466c-5cpj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"NodeJS monitoring agent","requires_auth":"none","summary":"An attacker or network issue causing OAP unavailability can render NodeJS services unavailable due to connection handling flaws in the SkyWalking agent.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"skywalking_nodejs_agent","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"A vulnerability in Apache SkyWalking NodeJS Agent prior to 0.5.1. The vulnerability will cause NodeJS services that has this agent installed to be unavailable if the OAP is unhealthy and NodeJS agent can't establish the connection.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Service unavailability impact in NodeJS agent(version \u003c= 0.5.0)","id":"CVE-2022-36127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2022-36129"},"packages":[{"ecosystem":"npm","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"skywalking-backend-js","purl":null,"source":"GHSA-8gpg-466c-5cpj"},{"ecosystem":"npm","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"skywalking-backend-js","purl":"pkg:npm/skywalking-backend-js","source":"GHSA-8gpg-466c-5cpj"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2022-36126"},"products":["Apache SkyWalking NodeJS Agent"],"published":"2022-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"An attacker or network issue causing OAP unavailability can render NodeJS services unavailable due to connection handling flaws in the SkyWalking agent.","url":"https://insights.sbomify.com/CVE-2022-36127/"}