# CVE-2022-36127: Service unavailability impact in NodeJS agent(version <= 0.5.0)

> An attacker or network issue causing OAP unavailability can render NodeJS services unavailable due to connection handling flaws in the SkyWalking agent.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8gpg-466c-5cpj

## What is CVE-2022-36127?

CVE-2022-36127 is a high-severity denial of service vulnerability in Apache SkyWalking NodeJS Agent, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in Apache SkyWalking NodeJS Agent prior to 0.5.1. The vulnerability will cause NodeJS services that has this agent installed to be unavailable if the OAP is unhealthy and NodeJS agent can't establish the connection.

## Which versions are affected by CVE-2022-36127?

2 open source packages ship an affected version, including skywalking-backend-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `skywalking-backend-js` | npm | All versions | 0.5.1 |
| `skywalking-backend-js` | npm | All versions | 0.5.1 |

Products: Apache Skywalking Nodejs Agent.

## How do I fix CVE-2022-36127?

Upgrade skywalking-backend-js to 0.5.1 or later.

## Is CVE-2022-36127 being exploited?

There is no known exploitation of CVE-2022-36127 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36127 and fix it if it is affected.

What it is: CVE-2022-36127 is a high-severity denial of service vulnerability in Apache SkyWalking NodeJS Agent, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36127 in the wild and no public exploit code.

Affected packages and fixed versions:
- skywalking-backend-js (npm): affected all versions; fixed in 0.5.1
- skywalking-backend-js (npm): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36127/ (Markdown: https://insights.sbomify.com/CVE-2022-36127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36127
- OSV: https://osv.dev/vulnerability/CVE-2022-36127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36127/
Summaries are generated and may contain mistakes; the official description above is the record.
