CVE-2022-36129 Missing authorization in n/a
Unauthenticated API allows overriding node voter status in Vault HA clusters, risking data loss or failure; requires Integrated Storage configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-36129?
CVE-2022-36129 is a critical missing authorization vulnerability in Hashicorp Vault, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HashiCorp Vault Enterprise 1.7.0 through 1.9.7, 1.10.4, and 1.11.0 clusters using Integrated Storage expose an unauthenticated API endpoint that could be abused to override the voter status of a node within a Vault HA cluster, introducing potential for future data loss or catastrophic failure. Fixed in Vault Enterprise 1.9.8, 1.10.5, and 1.11.1.
Weakness: CWE-306
Which versions are affected by CVE-2022-36129?
1 open source package ship an affected version, including vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vault Bitnami | From 1.7.0 | 1.9.8, 1.10.5, 1.11.1 |
Products include Hashicorp Vault.
How do I fix CVE-2022-36129?
Upgrade vault to a fixed version for your release line: 1.9.8, 1.10.5 or 1.11.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-36129 being exploited?
There is no known exploitation of CVE-2022-36129 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
- CVE-2020-35192 Hardcoded credentials in n/a
- CVE-2020-12757 Improper Input Validation in HashiCorp Vault
- CVE-2025-6000 Arbitrary Remote Code Execution via Plugin Catalog Abuse
- CVE-2022-40186 HashiCorp Vault vulnerable to incorrect metadata access
- CVE-2020-10661 HashiCorp Vault Improper Privilege Management
Sources
Also known as BIT-vault-2022-36129, GHSA-c8mv-ccvj-9h5q.