{"answers":{"affected":"1 open source package ship an affected version, including vault. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36129 in the wild and no public exploit code.","fix":"Upgrade vault to a fixed version for your release line: 1.9.8, 1.10.5 or 1.11.1.","what":"CVE-2022-36129 is a critical missing authorization vulnerability in Hashicorp Vault, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36129 and fix it if it is affected.\n\nWhat it is: CVE-2022-36129 is a critical missing authorization vulnerability in Hashicorp Vault, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36129 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vault (Bitnami): affected from 1.7.0; fixed in 1.9.8, 1.10.5, 1.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36129/ (Markdown: https://insights.sbomify.com/CVE-2022-36129/index.md)","id":"CVE-2022-36129","markdown":"https://insights.sbomify.com/CVE-2022-36129/index.md","name":"CVE-2022-36129","record":{"aliases":["BIT-vault-2022-36129","GHSA-c8mv-ccvj-9h5q"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"HashiCorp Vault Enterprise","requires_auth":"none","summary":"Unauthenticated API allows overriding node voter status in Vault HA clusters, risking data loss or failure; requires Integrated Storage configuration.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"vault","vendor":"hashicorp"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"HashiCorp Vault Enterprise 1.7.0 through 1.9.7, 1.10.4, and 1.11.0 clusters using Integrated Storage expose an unauthenticated API endpoint that could be abused to override the voter status of a node within a Vault HA cluster, introducing potential for future data loss or catastrophic failure. Fixed in Vault Enterprise 1.9.8, 1.10.5, and 1.11.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing authorization in n/a","id":"CVE-2022-36129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"hashicorp:vault","products":["hashicorp:vault"],"type":"missing_authorization","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2022-36130"},"packages":[{"ecosystem":"Bitnami","fixed":["1.9.8","1.10.5","1.11.1"],"introduced":["1.7.0","1.10.0","1.11.0"],"last_affected":[],"package":"vault","purl":"pkg:bitnami/vault","source":"BIT-vault-2022-36129"}],"prev":{"headline":"Service unavailability impact in NodeJS agent(version \u003c= 0.5.0)","id":"CVE-2022-36127"},"products":["n/a"],"published":"2022-07-26","related":[{"cvss_score":9.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2020-35192","kev_date_added":null,"published":"2020-12-17"},{"cvss_score":9.8,"headline":"Improper Input Validation in HashiCorp Vault","id":"CVE-2020-12757","kev_date_added":null,"published":"2020-06-10"},{"cvss_score":9.1,"headline":"Arbitrary Remote Code Execution via Plugin Catalog Abuse","id":"CVE-2025-6000","kev_date_added":null,"published":"2025-08-01"},{"cvss_score":9.1,"headline":"HashiCorp Vault vulnerable to incorrect metadata access","id":"CVE-2022-40186","kev_date_added":null,"published":"2022-09-22"},{"cvss_score":9.1,"headline":"HashiCorp Vault Improper Privilege Management","id":"CVE-2020-10661","kev_date_added":null,"published":"2020-03-23"},{"cvss_score":8.2,"headline":"Authentication Bypass by Spoofing and Insufficient Verification of Data Authenticity in Hashicorp Vault","id":"CVE-2020-16250","kev_date_added":null,"published":"2020-08-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Unauthenticated API allows overriding node voter status in Vault HA clusters, risking data loss or failure; requires Integrated Storage configuration.","url":"https://insights.sbomify.com/CVE-2022-36129/"}