CVE-2022-3613 Denial of service in GitLab

Medium 5.8 Published Updated

A crafted Prometheus Server query in GitLab can cause high resource consumption, leading to a Denial of Service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3613?

CVE-2022-3613 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. A crafted Prometheus Server query can cause high resource consumption and may lead to Denial of Service.

Weakness: CWE-400

Which versions are affected by CVE-2022-3613?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.5.7, 15.6.4, 15.7.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-3613?

Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-3613 being exploited?

There is no known exploitation of CVE-2022-3613 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3613, GHSA-4w2r-hhr3-c2wv, UBUNTU-CVE-2022-3613.

Is CVE-2022-3613 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free