CVE-2022-36130 Privilege escalation in n/a

Critical 9.9 Published Updated

Authorized users can escalate privileges across scopes due to missing data integrity checks in HashiCorp Boundary.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-36130?

CVE-2022-36130 is a critical vulnerability in n/a, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

HashiCorp Boundary up to 0.10.1 did not properly perform data integrity checks to ensure the resources were associated with the correct scopes, allowing potential privilege escalation for authorized users of another scope. Fixed in Boundary 0.10.2.

Weakness: CWE-345

Which versions are affected by CVE-2022-36130?

It affects 1 product.

Products include Hashicorp Boundary.

How do I fix CVE-2022-36130?

No fix has been published for CVE-2022-36130 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-36130 being exploited?

There is no known exploitation of CVE-2022-36130 in the wild and no public exploit code.

Sources

Also known as GHSA-h79m-9724-rw92.

Is CVE-2022-36130 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free