# CVE-2022-36130: Privilege escalation in n/a

> Authorized users can escalate privileges across scopes due to missing data integrity checks in HashiCorp Boundary.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-h79m-9724-rw92

## What is CVE-2022-36130?

CVE-2022-36130 is a critical vulnerability in n/a, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Boundary up to 0.10.1 did not properly perform data integrity checks to ensure the resources were associated with the correct scopes, allowing potential privilege escalation for authorized users of another scope. Fixed in Boundary 0.10.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2022-36130?

It affects 1 product.


Products: Hashicorp Boundary.

## How do I fix CVE-2022-36130?

No fix has been published for CVE-2022-36130 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-36130 being exploited?

There is no known exploitation of CVE-2022-36130 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-1052](https://insights.sbomify.com/CVE-2024-1052/): Boundary Vulnerable to Session Hijacking Through TLS Certificate Tampering (high 8.0)
- [CVE-2022-36182](https://insights.sbomify.com/CVE-2022-36182/): Hashicorp Boundary vulnerable to clickjacking (medium 6.1)
- [CVE-2024-12289](https://insights.sbomify.com/CVE-2024-12289/): Boundary Controller Incorrectly Handles HTTP Requests On Initialization Which May Lead to a Denial of Service (medium 5.9)
- [CVE-2023-0690](https://insights.sbomify.com/CVE-2023-0690/): Boundary Workers Store Rotated Credentials in Plaintext Even When a Key Management Service Configured (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36130 and fix it if it is affected.

What it is: CVE-2022-36130 is a critical vulnerability in n/a, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36130 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36130/ (Markdown: https://insights.sbomify.com/CVE-2022-36130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36130
- OSV: https://osv.dev/vulnerability/CVE-2022-36130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36130/
Summaries are generated and may contain mistakes; the official description above is the record.
