# CVE-2022-3616: OctoRPKI crash when maximum iterations number is reached

> Attackers can cause OctoRPKI to crash by submitting long CA chains, resulting in a denial of service for RPKI validation.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Oct 2022
- **Updated:** 5 May 2025
- **Also known as:** DEBIAN-CVE-2022-3616, GHSA-pmw9-567p-68pc, GO-2022-1089, UBUNTU-CVE-2022-3616

## What is CVE-2022-3616?

CVE-2022-3616 is a medium-severity denial of service vulnerability in Cloudflare OctoRPKI, published on 28 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Attackers can create long chains of CAs that would lead to OctoRPKI exceeding its max iterations parameter. In consequence it would cause the program to crash, preventing it from finishing the validation and leading to a denial of service. Credits to Donika Mirdita and Haya Shulman - Fraunhofer SIT, ATHENE, who discovered and reported this vulnerability.

Weakness: CWE-834 (Excessive Iteration), CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2022-3616?

3 open source packages ship an affected version, including github.com/cloudflare/cfrpki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.4 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.4 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.4 |

Products: Cloudflare Octorpki.

## How do I fix CVE-2022-3616?

Upgrade github.com/cloudflare/cfrpki to 1.4.4 or later.

## Is CVE-2022-3616 being exploited?

There is no known exploitation of CVE-2022-3616 in the wild and no public exploit code.

## Other vulnerabilities in Cloudflare OctoRPKI

- [CVE-2021-3978](https://insights.sbomify.com/CVE-2021-3978/): Improper Preservation of Permissions in github.com/cloudflare/cfrpki/cmd/octorpki (high 7.5)
- [CVE-2021-3761](https://insights.sbomify.com/CVE-2021-3761/): OctoRPKI lacks contextual out-of-bounds check when validating RPKI ROA maxLength values (high 7.5)
- [CVE-2021-3907](https://insights.sbomify.com/CVE-2021-3907/): Arbitrary filepath traversal via URI injection (high 7.4)
- [CVE-2021-3908](https://insights.sbomify.com/CVE-2021-3908/): Infinite certificate chain depth results in OctoRPKI running forever (medium 5.9)
- [CVE-2021-3909](https://insights.sbomify.com/CVE-2021-3909/): Infinite open connection causes OctoRPKI to hang forever (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3616 and fix it if it is affected.

What it is: CVE-2022-3616 is a medium-severity denial of service vulnerability in Cloudflare OctoRPKI, published on 28 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-3616 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.4
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.4
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3616/ (Markdown: https://insights.sbomify.com/CVE-2022-3616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3616
- OSV: https://osv.dev/vulnerability/CVE-2022-3616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3616/
Summaries are generated and may contain mistakes; the official description above is the record.
