CVE-2022-36359 Django vulnerable to Reflected File Download attack
Attackers can exploit reflected file download in Django's FileResponse to trick users into executing malicious files via user-controlled filenames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-36359?
CVE-2022-36359 is a high-severity vulnerability in Debian Debian Linux, published on 3 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in the HTTP FileResponse class in Django 3.2 before 3.2.15 and 4.0 before 4.0.7. An application is vulnerable to a reflected file download (RFD) attack that sets the Content-Disposition header of a FileResponse when the filename is derived from user-supplied input.
Weakness: CWE-494
Which versions are affected by CVE-2022-36359?
6 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 3.2.0 | 3.2.15, 4.0.7 |
django PyPI | All versions | 3.2.15 |
django PyPI | From 3.2 | 3.2.15, 4.0.7 |
django PyPI | From 4.0 | 4.0.7 |
Django PyPI | All versions | 3.2.15 |
Django PyPI | From 4.0 | 4.0.7 |
Linux distribution packages (3)
python-Django SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.3.3 |
python-Django openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.3.3 |
python-Django openSUSE:Tumbleweed | All versions | 4.1-1.1 |
Products include Debian Debian Linux, Djangoproject Django.
How do I fix CVE-2022-36359?
Upgrade django to a fixed version for your release line: 3.2.15 or 4.0.7.
Is CVE-2022-36359 being exploited?
There is no known exploitation of CVE-2022-36359 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2022-36359, DEBIAN-CVE-2022-36359, GHSA-8x94-hmjh-97hq, PYSEC-2022-245, ROOT-APP-PYPI-CVE-2022-36359, UBUNTU-CVE-2022-36359 and 3 more.