# CVE-2022-36359: Django vulnerable to Reflected File Download attack

> Attackers can exploit reflected file download in Django's FileResponse to trick users into executing malicious files via user-controlled filenames.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Aug 2022
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-django-2022-36359, DEBIAN-CVE-2022-36359, GHSA-8x94-hmjh-97hq, PYSEC-2022-245, ROOT-APP-PYPI-CVE-2022-36359, UBUNTU-CVE-2022-36359, USN-5549-1, openSUSE-SU-2022:10103-1, openSUSE-SU-2024:12236-1

## What is CVE-2022-36359?

CVE-2022-36359 is a high-severity vulnerability in Debian Debian Linux, published on 3 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the HTTP FileResponse class in Django 3.2 before 3.2.15 and 4.0 before 4.0.7. An application is vulnerable to a reflected file download (RFD) attack that sets the Content-Disposition header of a FileResponse when the filename is derived from user-supplied input.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2022-36359?

6 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.15, 4.0.7 |
| `django` | PyPI | All versions | 3.2.15 |
| `django` | PyPI | From 3.2 | 3.2.15, 4.0.7 |
| `django` | PyPI | From 4.0 | 4.0.7 |
| `Django` | PyPI | All versions | 3.2.15 |
| `Django` | PyPI | From 4.0 | 4.0.7 |
| `python-Django` | SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.3.3 |
| `python-Django` | openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.3.3 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.1-1.1 |

Products: Debian Debian Linux, Djangoproject Django.

## How do I fix CVE-2022-36359?

Upgrade django to a fixed version for your release line: 3.2.15 or 4.0.7.

## Is CVE-2022-36359 being exploited?

There is no known exploitation of CVE-2022-36359 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36359 and fix it if it is affected.

What it is: CVE-2022-36359 is a high-severity vulnerability in Debian Debian Linux, published on 3 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36359 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.15, 4.0.7
- django (PyPI): affected all versions; fixed in 3.2.15
- django (PyPI): affected from 3.2; fixed in 3.2.15, 4.0.7
- django (PyPI): affected from 4.0; fixed in 4.0.7
- Django (PyPI): affected all versions; fixed in 3.2.15
- Django (PyPI): affected from 4.0; fixed in 4.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36359/ (Markdown: https://insights.sbomify.com/CVE-2022-36359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36359
- OSV: https://osv.dev/vulnerability/CVE-2022-36359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36359/
Summaries are generated and may contain mistakes; the official description above is the record.
