CVE-2022-3639 Denial of service in GitLab

Medium 4.3 Published Updated

Attackers can trigger high CPU usage via improper data handling during branch creation, causing denial of service in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3639?

CVE-2022-3639 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 21 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A potential DOS vulnerability was discovered in GitLab CE/EE affecting all versions from 10.8 before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2. Improper data handling on branch creation could have been used to trigger high CPU usage.

Weakness: CWE-400

Which versions are affected by CVE-2022-3639?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.8.015.1.6, 15.2.4, 15.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-3639?

Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-3639 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3639 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3639, GHSA-fmg9-cqhf-254r, UBUNTU-CVE-2022-3639.

Is CVE-2022-3639 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free