{"answers":{"affected":"3 open source packages ship an affected version, including vncauthproxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36436 in the wild and no public exploit code.","fix":"Upgrade vncauthproxy to 1.2.0 or later.","what":"CVE-2022-36436 is a critical authentication bypass vulnerability in n/a, published on 14 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36436 and fix it if it is affected.\n\nWhat it is: CVE-2022-36436 is a critical authentication bypass vulnerability in n/a, published on 14 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36436 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vncauthproxy (PyPI): affected all versions; fixed in 1.2.0\n- vncauthproxy (PyPI): affected all versions; fixed in 1.2.0\n- vncauthproxy (PyPI): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36436/ (Markdown: https://insights.sbomify.com/CVE-2022-36436/index.md)","id":"CVE-2022-36436","markdown":"https://insights.sbomify.com/CVE-2022-36436/index.md","name":"CVE-2022-36436","record":{"aliases":["GHSA-237r-mx84-7x8c","PYSEC-2022-267"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"VNC authentication proxy","requires_auth":"none","summary":"Remote attackers can bypass authentication to access or disconnect VNC sessions via the VNCAuthProxy server without credentials.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"twisted_vnc_authentication_proxy","vendor":"osuosl"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"OSU Open Source Lab VNCAuthProxy through 1.1.1 is affected by an vncap/vnc/protocol.py VNCServerAuthenticator authentication-bypass vulnerability that could allow a malicious actor to gain unauthorized access to a VNC session or to disconnect a legitimate user from a VNC session. A remote attacker with network access to the proxy server could leverage this vulnerability to connect to VNC servers protected by the proxy server without providing any authentication credentials. Exploitation of this issue requires that the proxy server is currently accepting connections for the target VNC server.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"VNCAuthProxy authentication bypass vulnerability","id":"CVE-2022-36436","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Hazelcast connection caching","id":"CVE-2022-36437"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"vncauthproxy","purl":null,"source":"GHSA-237r-mx84-7x8c"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"vncauthproxy","purl":"pkg:pypi/vncauthproxy","source":"GHSA-237r-mx84-7x8c"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"vncauthproxy","purl":"pkg:pypi/vncauthproxy","source":"PYSEC-2022-267"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-36433"},"products":["n/a"],"published":"2022-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Remote attackers can bypass authentication to access or disconnect VNC sessions via the VNCAuthProxy server without credentials.","url":"https://insights.sbomify.com/CVE-2022-36436/"}